windshield wipers stalling/freezing issue - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
#1 Old 02-29-2012, 09:54 PM
New Member
 
Join Date: Feb 2012
Location: Maple Ridge, BC
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
windshield wipers stalling/freezing issue

Hi to everyone and thanks for me posting here.
I am posting this question for my girlfriend who drives a 2007 Versa.
What great reliable cars these are! And great on fuel!
One Safety issue though and that is that her windshield wipers stall often in any position in any setting.
Last night she drove home from work and this happened again. The wipers freeze in any position for about 8 to 10 seconds and then continue and it repeats intermittently.
It is very dangerous and I am concerned for her safety and others on the road.

Does anyone have an idea what it could be or what I should check/replace?
Is this a common issue? I did a search and nothing came up.

Any feedback much appreciated.

Cheers.
BobbiB is offline  
Sponsored Links
Advertisement
 
#2 Old 02-29-2012, 10:04 PM
Level IV Member
 
06_warrior's Avatar
 
Join Date: Jul 2011
Location: Florida, U.S.A.
Posts: 271
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
I see this is your first post so welcome to our community. Sounds like it has something to do with the intermittent part of the wiper system. I'm thinking maybe you should change the wiper control that is connected to the steering column. See if you can get one cheap from a salvage yard and start from there. Also i had a ford wagon once years ago that the wiper motor crapped the bed and i used Rain-X on the windshield with no wipers on the highway and the rain beaded away and i got to and from my destination just fine. Try using that until you get the problem with the wipers fixed.

Last edited by 06_warrior; 02-29-2012 at 10:06 PM.
06_warrior is offline  
#3 Old 04-26-2012, 12:10 AM
New Member
 
Join Date: Feb 2012
Location: Maple Ridge, BC
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I thought I'd update this posting with my fix.

I could not come across any info related to a fix for this problem so I first went to check the connections and stalk on the steering column. I took it all apart and did not notice any issues with a bad connection, worn or broken parts. So I put it all back together and went to the wiper motor and removed it from the car. Then I removed the motor housing from the unit and noticed a lot of dust buildup on the magnets of the housing so I cleaned it. Then I used this contact cleaner I have and sprayed inside the housing and on the wire wound parts. Basically sprayed all and let dry then reassembled all parts and reinstalled the motor back in the car.
I am happy to report that the wipers have never stalled again and this is after months of heavy rain here on the Wetcoast!

Cheers.
BobbiB is offline  
#4 Old 04-26-2012, 01:24 AM
Level VI Member
 
08versailles's Avatar
 
Join Date: Oct 2010
Location: Haldimand ON Canada
Posts: 2,378
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Feedback Score: 0 reviews
Awesome fix, great postWelcome BobbiB!

08 Versa SL hatch 1.8 manual 250000km 2012avg41.5mpgImp. Muffler delete video http://www.youtube.com/watch?v=mIl3p...ature=youtu.be
09 Altima 2.5S cvt NEW MOTOR@90k WRITTEN OFF at 139k 34.4mpgImp. http://www.nissanversaforums.com/non...09-altima.html
13 Charger SXT 3.6 8sp ZFauto 49000km
01 Sentra XE manual, parted ways at 313000km
72 Datsun 1200 Deluxe two door sedan manual, took a beatin' while I learned to drive
08versailles is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On