Service Engine Soon: P1421 - Nissan Versa Forums
General Versa Discussion Everything about Versa's that does not fit in another forum

User Tag List
radboy68

 2Likes
  • 1 Post By rstolz
  • 1 Post By r2urbo
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 03-31-2014, 01:24 AM Thread Starter
New Member
 
Join Date: Mar 2014
Location: New Jersey
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Service Engine Soon: P1421

well, my car is a 2008. I recently bought my versa from a toyota dealership actually... Feb 15. Before i bought it i DID take it to a mechanic to have them check it out... and everything seemed fine... until today..

While I feel my car drives perfectly, my Service Engine Soon light came on. I went to autozone to get their free diagnostic test and it came up with the code P1421... and well, my filter was squeeky clean, so I ended up buying fuel injector instead. I know that takes time to take effect i guess. but i worry that if that doesnt work and my engine light still remains on... i may have to look into the faulty engine control module repair?

seriously, i am no car expert so i have no idea what the ECM would entail or how much it would cost. i would like to know that sorta information if anyone knows..

and oh, i did check my gas cap and it was on tightly...

and i tried looking online to reprogram the service engine light and to no avail, i have not been able to be successful at that..

anyways, despite my light being on, my car seems to still run perfectly...
and my car has 45k miles on it.

if anyone has any insights of my issue, feedback would be much appreciated.

Last edited by tonijoy; 03-31-2014 at 01:29 AM.
tonijoy is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-31-2014, 02:10 AM
Level V Member
 
07Versa6MT's Avatar
 
Join Date: Oct 2013
Location: London, Ontario
Posts: 689
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 127 Post(s)
Garage
Feedback Score: 0 reviews
PCM's do rarely go bad, but it usually is a no-start when they do. Clear it and see during what conditions it comes back. It is a code where there is probably a threshold value, so you can't really pinpoint when it happens unless you have a cheap little scanner plugged in and see when you get a pending code, or freeze frame codes. Unfortunately it's one of those stupid vague codes that could be many things. It could likely be a random ass code, however if it's happened frequently enough to set the check engine light.

How do your grounds look? Always worth cleaning your grounds. The battery ground goes to the chassis, then to the tranny, there is one on the passenger side near alternator, and a couple other ones coming out of the harness and grounding on the core support.
07Versa6MT is offline  
post #3 of 9 Old 03-31-2014, 04:03 AM Thread Starter
New Member
 
Join Date: Mar 2014
Location: New Jersey
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
thanks. i admit, i have no idea what you ended up saying but thanks tho for the feedback. i am not a car person at all. so yeah, i had a guy friend look at my car he double checked my filter. i had checked it at autozone... but i guess i didn't check it thoroughly enough on BOTH sides. i was told i should buy a new filter. ALSO, with numerous tries he ended up clearing the service engine light. (its all about exact timing, i guess) So, for now the light is off and tomorrow i'm headed to autozone again to buy a new filter. hope that does the trick.

even tho i bought this used, my car runs really smoothly. its the quietest car i've ever owned. i am feeling a little better now thinking there is nothing major going wrong with it...

all i gotta say for now...

GOD BLess guy friends who know about cars...
tonijoy is offline  
 
post #4 of 9 Old 03-31-2014, 05:52 PM
Level IV Member
 
Join Date: Mar 2014
Location: Northern IL
Posts: 226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage
Feedback Score: 0 reviews
http://engine-codes.com/uploads/nissan/NTB09-116.pdf

follow the link, or print it and bring it to a Nissan mechanic. They'll need to have specific Nissan computer system "Consult-III", so you may need to take it to a Nissan dealer. A general Mechanic will not likely have access to the software needed.

This is a Technical Service Bulletin Distributed by Nissan, covering a known fault in the ECM (engine's computer). The fault isn't severe enough to be a recall, but it is known and frequent enough that they know exactly what to do.
Francesco likes this.
rstolz is offline  
post #5 of 9 Old 03-31-2014, 06:12 PM
Level VI Member
 
robj80's Avatar
 
Join Date: Apr 2009
Location: central, CT
Posts: 3,262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 122 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by rstolz View Post
http://engine-codes.com/uploads/nissan/NTB09-116.pdf

follow the link, or print it and bring it to a Nissan mechanic. They'll need to have specific Nissan computer system "Consult-III", so you may need to take it to a Nissan dealer. A general Mechanic will not likely have access to the software needed.

This is a Technical Service Bulletin Distributed by Nissan, covering a known fault in the ECM (engine's computer). The fault isn't severe enough to be a recall, but it is known and frequent enough that they know exactly what to do.

Fantastic post ^^. We should host that on this site in case the link stops working.


205,125 miles when she was given away
35 mpg last tank


̶w̶a̶i̶t̶i̶n̶g̶ ̶f̶o̶r̶ ̶h̶e̶r̶ ̶t̶o̶ ̶d̶i̶e̶ ̶s̶o̶ ̶I̶ ̶c̶a̶n̶ ̶b̶u̶y̶ ̶a̶ ̶t̶r̶u̶c̶k̶,̶ ̶b̶u̶t̶ ̶s̶h̶e̶ ̶w̶o̶n̶'̶t̶ ̶d̶i̶e̶ She didn't die but I bought the truck anyway!!
robj80 is offline  
post #6 of 9 Old 10-27-2014, 08:31 PM
New Member
 
Join Date: Jun 2013
Location: Providence, RI
Posts: 1
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 1 Post(s)
Garage
Feedback Score: 0 reviews
I have a 2010 Versa SL hatchback. I just got the P1421 code. I have no drivability issues and checked for a clogged air filter. Do you think the Nissan Service Bulletin could apply to my car even though it says 2007-2009?
radboy68 is offline  
post #7 of 9 Old 01-05-2016, 04:16 PM
New Member
 
Join Date: Jan 2016
Location: Chicago
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
p1421 code

Quote:
Originally Posted by radboy68 View Post
I have a 2010 Versa SL hatchback. I just got the P1421 code. I have no drivability issues and checked for a clogged air filter. Do you think the Nissan Service Bulletin could apply to my car even though it says 2007-2009?
@radboy68 did you take it to the Nissan dealership? I have the same issue and I have the 2010 Versa SL hatchback as well.
r2urbo is offline  
post #8 of 9 Old 01-05-2016, 05:02 PM
Level I Member
 
Join Date: Nov 2012
Location: USA
Posts: 35
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 4 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by r2urbo View Post
@radboy68 did you take it to the Nissan dealership? I have the same issue and I have the 2010 Versa SL hatchback as well.
Now that the weather is cold I've been throwing this code more frequently. No drivability symptoms so I plug in my wifi OBDII device and clear the code with the app on my phone. I would go to the dealer and have them perform the TSB, but I'm sure they would charge me or want me to be in there for another service.
nissanversa08 is offline  
post #9 of 9 Old 01-08-2016, 08:27 PM
New Member
 
Join Date: Jan 2016
Location: Chicago
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Just an update. I took my 2010 Nissan Versa SL Hatchback to the Nissan dealership and they determined it was the ECM issue. They reprogrammed it for free because it was still under warranty.
Notarized likes this.
r2urbo is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On