Nissan Versa Forums - View Single Post - Nissan Versa 2010 hb Fuel pump not priming problem
View Single Post
post #1 of Old 04-14-2016, 06:55 PM Thread Starter
versa24
New Member
 
Join Date: Apr 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Nissan Versa 2010 hb Fuel pump not priming problem

Hi, new here and Im having a problem with my versa 2010 fuel pump not priming and car cranking but not starting.

So far I have tried putting starting fluid down the front air intake and when I crank it actually starts and stalls a couple seconds later. So im thinking fuel delivery problem and noticed that I could never hear the fuel pump prime when I turn the key to the on position.

So I take my rear seat out and take the cap off the pump and the pump still is not priming since I should hear it better this way.

Also I have checked the 15a fuel pump fuse and it was ok and even replaced it and still nothing.

So I went ahead and purchased a brand new delphi fuel pump and installed it and still the same problem which I realized I diagnosed this wrong so far.

I need help determining my next action and how to test the ipdm or if there can be a break in the brown wire or something even though I actually got like 11.6 volts at the fuel pump harness brown wire at the fuel pump. Also is there a way to bypass or jump the fuel pump relay which is my understanding that it is internal to the ipdm and not serviceable?

Also my ipdm is the type b which has no external fuel pump relay it just has like a fogger and ignition relay

Thank you.
Attached Thumbnails
Click image for larger version

Name:	ipdm_b.jpg
Views:	1746
Size:	8.1 KB
ID:	13289  
versa24 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome