2012 Versa A/C problem - Nissan Versa Forums
Engine Forum Discuss about engine mods, swaps, exhaust, ECU tuning & forced induction here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-07-2015, 07:01 PM Thread Starter
New Member
 
Join Date: Jun 2013
Location: North Carolina
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2012 Versa A/C problem

I have 2012 Versa and it will not hold a charge for A/C. I have a leak somewhere. Is this common for these cars?
Added freon twice>blew cold> next morning no A/C again
put in the dye and can't see anything.
I have been told it's most likely the evaporator since the condenser and the compressor seem to be working fine.
Hoping maybe it's just a hose leaking somewhere.
Also anyone have a ball park price of what I might expect to get it fixed?
thanks!
DebzVersa is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-09-2015, 03:50 AM
Level VI Member
 
08versailles's Avatar
 
Join Date: Oct 2010
Location: Haldimand ON Canada
Posts: 2,469
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 53 Post(s)
Feedback Score: 0 reviews
I had my evaporator replaced last year after topping up refrigerant a few times. After mechanic added the leak dye, the leak in middle of evaporator was very evident.
I used an independent mechanic and he did not tear apart the dash to do the job, as indicated by Nissan service manual. Easy to find the YouTube vid, search versa evaporator replace, etc.
Was $500 Cdn all in, will be cheaper in the US.
Welcome to the NVF Deb!

08 Versa SL hatch 1.8 manual TRADED 288516km Muffler delete video http://www.youtube.com/watch?v=mIl3p...ature=youtu.be
09 Altima 2.5S cvt NEW [email protected] WRITTEN OFF at 139k 34.4mpgImp. https://www.nissanversaforums.com/non...09-altima.html
13 Charger SXT 3.6 8sp ZFauto 89000km
01 Sentra XE manual, parted ways at 313000km
72 Datsun 1200 Deluxe two door sedan manual, took a beatin' while I learned to drive
08versailles is offline  
post #3 of 4 Old 04-09-2015, 02:06 PM
Level VI Member
 
robj80's Avatar
 
Join Date: Apr 2009
Location: central, CT
Posts: 3,272
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 124 Post(s)
Feedback Score: 1 reviews
my 2009 is the same way. I have topped it off twice or so and I can not find the leak. It has to be behind the dash. Really sucks that after only 3 years I had this issue and been dealing with it since.

I might rip the dash apart this year and finally try and see what is up.


205,125 miles when she was given away
35 mpg last tank


̶w̶a̶i̶t̶i̶n̶g̶ ̶f̶o̶r̶ ̶h̶e̶r̶ ̶t̶o̶ ̶d̶i̶e̶ ̶s̶o̶ ̶I̶ ̶c̶a̶n̶ ̶b̶u̶y̶ ̶a̶ ̶t̶r̶u̶c̶k̶,̶ ̶b̶u̶t̶ ̶s̶h̶e̶ ̶w̶o̶n̶'̶t̶ ̶d̶i̶e̶ She didn't die but I bought the truck anyway!!
robj80 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 04-27-2015, 11:58 PM Thread Starter
New Member
 
Join Date: Jun 2013
Location: North Carolina
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
estimate for high end pressure hose

So, I took my Versa to a mechanic. They charged the system and added dye. They told me they replaced the Schrader valves, 22.00. 2 hours later I got there to pick up the car and it blew warm air again. The mechanic told me to leave it another day which I did. He told me he would give me an estimate for the High end/pressure assembly. I had a friend check the price of the part, 70.00 or so. I got an email today from the mechanic with an estimate of 759.00. He said he couldn't find the part local and would check with a dealer. I'm so frustrated. You just can't get by in the south with no A/C. When I call tomorrow I will ask him to order the cheaper part even if I have to wait. He also told me the first time he would credit me the money I have already paid the first time. But I see no credit on the estimate. Hoping a male friend can help with talking to this mechanic. So frustrated at this. This car is only 3 years old. Any suggestions?
DebzVersa is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome