maf sensor - Nissan Versa Forums
Engine Forum Discuss about engine mods, swaps, exhaust, ECU tuning & forced induction here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-16-2015, 10:24 PM Thread Starter
Level I Member
 
arielleon956's Avatar
 
Join Date: Sep 2013
Location: harlingen texas
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
maf sensor

Anybody have problems with the air massflow sensor my check engine light came on recently and they pulled that the sensor not good not the first time this happens thou.
arielleon956 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-17-2015, 12:01 AM
Level II Member
 
D3R3K's Avatar
 
Join Date: Oct 2015
Location: Maryland
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Feedback Score: 0 reviews
Did you have it replaced before?
D3R3K is offline  
post #3 of 5 Old 12-17-2015, 09:22 PM
Level V Member
 
Join Date: Sep 2012
Location: USA
Posts: 440
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Feedback Score: 0 reviews
Remove it, clean it with some electronics cleaner spray, wipe all connectors and sensors with the spray using a qtip, replace maf sensor, remove the negative battery cable or main fuse and leave some sort of light on (like leaving your door open) for a couple minutes, and then restart the car. See if the CEL went away or the problem continues.
Versa12 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 12-18-2015, 03:43 AM Thread Starter
Level I Member
 
arielleon956's Avatar
 
Join Date: Sep 2013
Location: harlingen texas
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
Hasnt been replaced before I've only had the car 2years and the last time this happened i had cleaned it. It worked until now this was last year when i cleaned it.

2012 versa hatchback

225/30/20 hd921 gazario 782 chrome no suspension upgrades

Soundstream 7inch single din 2 12s xtreme audio subs 3000 watt mono block quantum audio

6k hid n led licence plate
arielleon956 is offline  
post #5 of 5 Old 12-18-2015, 10:27 AM
Level II Member
 
D3R3K's Avatar
 
Join Date: Oct 2015
Location: Maryland
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Feedback Score: 0 reviews
If you have a aftermarket oiled type air filter, the oil can get on the sensor and throw a fault for it
D3R3K is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome