CAI filter cleaning - Nissan Versa Forums
Engine Forum Discuss about engine mods, swaps, exhaust, ECU tuning & forced induction here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 08-28-2009, 05:24 AM Thread Starter
Member
 
Join Date: Mar 2009
Location: Denver, CO
Posts: 3,417
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
CAI filter cleaning

Once you have the CAI installed, when it needs cleaning how do you access it when it's deep in the engine compartment? Seems like it would be difficult to reach down in there.

Is it necessary to disassemble the CAI to clean the filter and install in reverse order? That sounds like a PITA IMO. How do you guys do it?
Hschlick84 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-28-2009, 07:18 AM
Banned
 
Join Date: Aug 2008
Location: Los Angeles, CA
Posts: 1,208
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Send a message via AIM to superskunk
I usually take off the front bumper, but you can get to it from the inner fender.... just hope that when you installed it you placed the clamp toward the back so you take it off to remove the filter....
superskunk is offline  
post #3 of 8 Old 08-28-2009, 10:53 AM
Level VI Member
 
AusTiida's Avatar
 
Join Date: Oct 2008
Location: South Australia
Posts: 867
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
this is so why I am building a custom CAI.....stuff that for a joke! :P
AusTiida is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 08-28-2009, 02:23 PM Thread Starter
Member
 
Join Date: Mar 2009
Location: Denver, CO
Posts: 3,417
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by superskunk View Post
I usually take off the front bumper, but you can get to it from the inner fender.... just hope that when you installed it you placed the clamp toward the back so you take it off to remove the filter....
Yeah...when the filter is scheduled for cleaning, I don't want to go through the hassle and have to remove the bumper. Good idea.
Hschlick84 is offline  
post #5 of 8 Old 09-01-2009, 06:47 AM
Banned
 
Join Date: Aug 2008
Location: Los Angeles, CA
Posts: 1,208
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Send a message via AIM to superskunk
i really dont mind taking my bumper of, it gives me the chance to clean off the radiator....
superskunk is offline  
post #6 of 8 Old 09-01-2009, 08:36 AM
Level VI Member
 
AusTiida's Avatar
 
Join Date: Oct 2008
Location: South Australia
Posts: 867
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
haha, good point :P
AusTiida is offline  
post #7 of 8 Old 09-02-2009, 08:43 PM
Level II Member
 
BlueMango's Avatar
 
Join Date: Mar 2009
Location: Huntington Beach, CA
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I just peeled back the wheel liner to get access. Or you can put the car up and crawl underneath.
BlueMango is offline  
post #8 of 8 Old 09-03-2009, 05:30 PM
Administrator
 
Tubtub's Avatar
 
Join Date: Jul 2008
Location: The Nether
Posts: 5,026
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by BlueMango View Post
I just peeled back the wheel liner to get access. Or you can put the car up and crawl underneath.
x2. Just cut the wheel and remove the couple of clips on the front of in the inner liner and remove the filter.




2014 Subaru WRX
1997 Nissan 200SX SE-R
Tubtub is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome