Loose front bumper? Help please! - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 3Likes
  • 1 Post By JoshG
  • 1 Post By sergmx
  • 1 Post By JoshG
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 05-25-2014, 04:38 PM Thread Starter
Level III Member
 
BloodyChucklz's Avatar
 
Join Date: Oct 2011
Location: Arkansas
Posts: 166
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Garage
Feedback Score: 0 reviews
Loose front bumper? Help please!

After the first time removing my front bumper, I've never been able to get it locked in place properly in the front. Any suggestions?
Attached Thumbnails
Click image for larger version

Name:	IMG_20140525_112554.jpg
Views:	460
Size:	92.8 KB
ID:	6370  
BloodyChucklz is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 02-03-2016, 09:00 PM Thread Starter
Level III Member
 
BloodyChucklz's Avatar
 
Join Date: Oct 2011
Location: Arkansas
Posts: 166
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Garage
Feedback Score: 0 reviews
Resurrecting this thread for some fresh eyes. I'm planning on painting my car soon so I want to have the body in as good shape as possible before I start.
BloodyChucklz is offline  
post #3 of 10 Old 02-04-2016, 10:23 AM
Level II Member
 
D3R3K's Avatar
 
Join Date: Oct 2015
Location: Maryland
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Feedback Score: 0 reviews
Do you have anymore pictures?
D3R3K is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 02-05-2016, 04:36 PM
Administrator
 
JoshG's Avatar
 
Join Date: Apr 2010
Location: Tampa, FL
Posts: 4,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 90 Post(s)
Feedback Score: 0 reviews
Mine looks like that. How are the sides?
BloodyChucklz likes this.
JoshG is offline  
post #5 of 10 Old 02-08-2016, 05:05 PM
Super Moderator
 
sergmx's Avatar
 
Join Date: Mar 2012
Location: VA
Posts: 790
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Garage
Feedback Score: 0 reviews
Send a message via Skype™ to sergmx
Quote:
Originally Posted by BloodyChucklz View Post
After the first time removing my front bumper, I've never been able to get it locked in place properly in the front. Any suggestions?
What Josh said, how are the sides? You may have some side clips broken, I've had that happen to me before. I would personally remove the grill and front bumper, check the issues, and then re-mount to see how the fitment goes. Mount and check, mount and check..also once your bumper is removed, you can then see if any clips or anything is broken..good luck
BloodyChucklz likes this.

Enjoy Life.
2012 Versa HB 6-Speed.
Clean and Simple.
sergmx is offline  
post #6 of 10 Old 02-08-2016, 05:31 PM Thread Starter
Level III Member
 
BloodyChucklz's Avatar
 
Join Date: Oct 2011
Location: Arkansas
Posts: 166
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Garage
Feedback Score: 0 reviews
I'll have to remove all that soon to install new projectors anyway, so we will see how it goes. If the clips are broken, I hope I can find a way to make it work. The sides seem to fit nice the way they are supposed to.
BloodyChucklz is offline  
post #7 of 10 Old 02-12-2016, 04:07 AM
Administrator
 
JoshG's Avatar
 
Join Date: Apr 2010
Location: Tampa, FL
Posts: 4,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 90 Post(s)
Feedback Score: 0 reviews
There are no clips down there. They're all by the grille. Each headlight has a bracket the bumper slides into so I would look into that.
BloodyChucklz likes this.

2010 NISSAN VERSA 1.6
1991 MAZDA B2600i
JoshG is offline  
post #8 of 10 Old 03-13-2016, 06:16 PM Thread Starter
Level III Member
 
BloodyChucklz's Avatar
 
Join Date: Oct 2011
Location: Arkansas
Posts: 166
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Garage
Feedback Score: 0 reviews
I think I've found my problem. In order to install my billet grille I had to cut away the center section that holds the bumper up. This is the section that normally would connect to the area near the hood release latch for support. Also, I'm missing a few nuts/bolts on the bottom of the bumper as well, so there isn't much keeping it from sliding down. I'll replace the nuts/bolts today before I reinstall my headlights (fresh repaint, see my headlight tint thread) and hopefully that will help a little. Before I removed the headlights I checked the little slots at the bottom where they are supposed to grab the bumper and give it some support. Everything lined up correctly but there just didn't seem to be much of a grip there.

BloodyChucklz is offline  
post #9 of 10 Old 03-15-2016, 12:40 AM
Super Moderator
 
sergmx's Avatar
 
Join Date: Mar 2012
Location: VA
Posts: 790
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Garage
Feedback Score: 0 reviews
Send a message via Skype™ to sergmx
Like Josh said before, there is a place where the bumper slides into under the headlights. That should get rid of the clearance issue from your first post. I hope you get it all square away!

Enjoy Life.
2012 Versa HB 6-Speed.
Clean and Simple.
sergmx is offline  
post #10 of 10 Old 03-15-2016, 07:37 PM Thread Starter
Level III Member
 
BloodyChucklz's Avatar
 
Join Date: Oct 2011
Location: Arkansas
Posts: 166
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Garage
Feedback Score: 0 reviews
Quote:
Originally Posted by sergmx View Post
Like Josh said before, there is a place where the bumper slides into under the headlights. That should get rid of the clearance issue from your first post. I hope you get it all square away!
My bottom headlight clips are just not up to the task. I'm almost certain the missing support at the very front of the bumper is allowing it to sag down.
BloodyChucklz is offline  
Reply




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome