Horn stopped working - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-30-2010, 01:34 AM Thread Starter
New Member
 
Join Date: Aug 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Horn stopped working

Hi guys,

I"m new to the forum and have a little problem here.

So last week I bought a 09 Versa Hatchback from a Nissan Dealership. The car had 3,200 miles on it. When I bought the car I tested everything,radio,wipers,cruise,horn,power everything, and everything worked.

Yesterday my horn did not respond when I tapped so I pressed harder.. it worked. then I tried few times and it was not responsive and then stopped working for good.

My boat mechanic friend looked at the fuse and relay, the relay clicks when I press the horn in the steering wheel, and he probe with his test light. His though is that the horn itself is bad.

So I don't know if it is the the horn itself or something else.


Any ideas? I'm kinda a scare that I bought a bad versa. I hope is not the case cause I love the car. I'm bringing the car to the dealer tomorrow.
peruchox is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-30-2010, 11:30 PM
New Member
 
Join Date: Feb 2010
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
First off - with only 3200 miles the car is still under warranty.

I had a horn go bad on my '01 Sentra not a year after I bought it. Replaced under warranty. Sometimes it really is just a bad part.

And they should do it for you quickly because a non-working horn is a safety hazard.

--*Rob
robusdin is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome