Transmission leak from front pump seal- replaced but now leaking again - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-07-2016, 06:22 AM Thread Starter
Level I Member
 
Join Date: Jun 2015
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Transmission leak from front pump seal- replaced but now leaking again

I recently replaced the torque converter seal in my 07 versa.
After a 10 mile test drive i noticed it was leaking again.
I removed the motor and transmission together out the bottom- pretty lengthly process and im not thrilled to have to go through it again.
The transmission shifts fine and operates smoothly.
Im really thinking about just buying a salvage transmission for my next go around.
Im guessing the input shaft bearing is bad causing excessive play in the torque converter wiping out the seal.
I cant find a single problem like this on the web involving the versa 4 spd trans.
If anyone has any insight as to what might be causing this problem im open tosuggestions.
knuckleduster271 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome