Air bag light reset not working - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 1Likes
  • 1 Post By pimperell
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-01-2016, 09:36 PM Thread Starter
New Member
 
Join Date: Jul 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Air bag light reset not working

Hi all,

I drive a 2009 Nissan Versa HB.

My air bag light went off a couple days ago.

I tried the resetting procedure (turn it off and on 3 times) but it works for 2 mins and then starts blinking again.

Any ideas on what it could be without having to spend hundreds of $ for something stupid (if it is)?

Thanks!
Marco is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-04-2016, 06:02 AM
Level II Member
 
whicky1978's Avatar
 
Join Date: Jan 2014
Location: Clarksville
Posts: 85
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
I have the same issue for a while now, no solution. It started when I installed a new battery.
whicky1978 is offline  
post #3 of 3 Old 09-05-2016, 02:51 PM
Level V Member
 
Join Date: Sep 2012
Location: New Jersey
Posts: 651
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Marco View Post
Hi all,

I drive a 2009 Nissan Versa HB.

My air bag light went off a couple days ago.

I tried the resetting procedure (turn it off and on 3 times) but it works for 2 mins and then starts blinking again.

Any ideas on what it could be without having to spend hundreds of $ for something stupid (if it is)?

Thanks!

Never tried this, but its worth a try:


First, turn on your car (ON key position) and your airbag light stays on for 7 seconds, then starts flashing every half second. (.5 seconds on, .5 seconds off, repeat)
This means either your airbag is malfunctioning, or it malfunctioned in the past. We'll find out exactly what happened in a second.

If your airbag light is on solid the whole time, either your airbag has deployed, the computer thinks its deployed, or your sensor or wire harness is broken. You're going to need a professional to fix this.

If your light never comes on at all, your METER fuse might be blown, or you might have a wiring fault in an airbag circuit.
OK, so your light is flashing like I explained before. Next, we're going to enter DIAGNOSIS mode. This mode will tell you exactly what’s wrong with your airbag (according to the computer at least) It's a bit tricky, but read carefully.

1. Turn ignition switch “ON”.
2. After “AIR BAG” warning lamp lights for 7 seconds, [i.e. when it stops running solid and starts flashing] turn ignition switch “OFF” within 1 second. [DO NOT SWITCH IT TO LOCK, SWITCH IT TO ACC]
3. Wait more than 3 seconds.
4. Repeat steps 1 to 3 two times. (Perform 3 times in total.)
5. Turn ignition switch “ON”.
SRS is now in Diagnosis mode.

Try it a few times. If you can't get it to work, have someone else try. If you STILL can't get it to work, check your battery voltage. It might be low.

In diagnosis mode, you're going to hope the light flashes slowly. 2 seconds off, 3 seconds on, and repeats. If your light does this, this means that the computer detected a previous error that hasn't been erased. This is good.

If you get ANY OTHER result, you've got a real problem that needs a real fix.

Now, to erase the error from memory.

5. If “AIR BAG” warning lamp operates as [as I said before], turn ignition switch “OFF” to reset from Diagnosis mode
to User mode and to erase the memory of the malfunction.

6. Turn ignition switch “ON”. “AIR BAG” warning lamp operates in
User mode. [it should stay on for 7 seconds, then go off, like normal.]

Hope this helps you.
BloodyChucklz likes this.
pimperell is online now  
Reply

Tags
airbag light

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome