Coolant leak, can't find the source. - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-06-2016, 07:47 PM Thread Starter
New Member
 
Join Date: Oct 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Question Coolant leak, can't find the source.

I have a 2010 versa sedan 1.8L. Several months ago, it started overheating, and while trying things like a new thermostat and other easy fixes first, I managed to miss the fact that the radiator fan was broken, and I eventually burned up my radiator and had it replaced. Since then, it has been losing coolant and a pretty rapid rate. I refill the reservoir and under the radiator cap at least every 3-4 days to keep it from overheating again. The fan works fine this time, the thermostat was replaced while I was trying to figure out what was wrong with it before, I just got a completely new reservoir after the cap went missing (somehow a new reservoir was cheaper than just a cap), and the radiator cap itself is good to go. What I notice happening, is that on some days after driving, after the car cools for a little while, coolant will have leaked from somewhere near the passenger side wheel well. I just a little while ago filled up my reservoir, filled up under the radiator cap, left the cap off, and started the car to see if I had any bubbling from under the cap, as the way I understand it that could be due to a blown head gasket, although I haven't had any issues with white smoke in my exhaust or milky oil. I left the car running with the cap off for a few minutes, and saw the coolant level under the cap rise a bit, and then stay level. I placed the cap back on and let the car idle for near 30 minutes, giving it gas for minutes at a time trying to see if it would overheat, as it tends to still overheat from time to time while stopped or idle. Couldn't get it to overheat and saw no leaks while it was running. So, I shut it off and let it sit for about 15 minutes before deciding to check reservoir levels. As of now, the level in the reservoir is slightly lower than before I had started the car, but there is a small amount of coolant on the ground near the passenger side wheel, though much less than I notice had I driven the car anywhere. And, though I don't want to remove the radiator cap just yet to confirm, I can feel by squeezing the upper radiator hose that is is empty, which is usually the case every day I check the coolant levels. As far as I have read, this should not normally be the case, but rather that coolant should be up to the radiator cap after fluid is siphoned from reservoir during cooling. The only other information I can really offer is that I have at times noticed coolant on top of the reservoir, as though it had leaked from the vent under the cap, and this is usually after I have refilled the reservoir (not passed the max line).

Believe me when I say that I have Googled for weeks trying to figure out what's going on with my coolant. I couldn't find anything on here that really fit my problem, so I apologize if this has already been answered in another thread.
SuperSathanas is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-08-2016, 03:18 PM Thread Starter
New Member
 
Join Date: Oct 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
As a follow up, I also noticed a sweet smell this morning when I had the heat blowing through the engine vent. Coolant is burning somewhere.
SuperSathanas is offline  
post #3 of 3 Old 10-08-2016, 04:50 PM
Level V Member
 
Join Date: Sep 2012
Location: New Jersey
Posts: 651
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by SuperSathanas View Post
As a follow up, I also noticed a sweet smell this morning when I had the heat blowing through the engine vent. Coolant is burning somewhere.
You may have a leak in the heater core or the hoses that are attached that is giving you that "sweet smell" in the morning. Anti freeze will usually seep out onto the heater core, and in turn the sweet smell will end up in the cabin. If it is the heater core, you will either have to have it replaced, or you might want to try one of the radiator sealants that they sell at most auto supply stores. Some of the newer sealants on the market today can work pretty well if your not inclined to replace the heater core. Good luck
pimperell is online now  
Reply

Tags
coolant , leak , passenger , side

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome