Left rear brake light keeps going out. Help? - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-31-2016, 05:23 AM Thread Starter
New Member
 
Join Date: Apr 2015
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Left rear brake light keeps going out. Help?

Anyone having this problem with any of their light fixtures? My left rear brake light keeps going out, and by going out, i mean, like, power stops reaching it. I cant figure it out and im afraid to rip into the wiring to check. Litterally if i remove the bulb and put it back in, it works.......for a couple days, then goes back out again. Nothing wrong with the bulb itself. I even changed it to be sure. Same thing. Super annoying since im a full time lyft driver and im ALWAYS on the road at night. Id rather not end up with a ticket lol.
Skydona is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-01-2016, 01:26 PM
Level V Member
 
Join Date: Sep 2012
Location: New Jersey
Posts: 651
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Skydona View Post
Anyone having this problem with any of their light fixtures? My left rear brake light keeps going out, and by going out, i mean, like, power stops reaching it. I cant figure it out and im afraid to rip into the wiring to check. Litterally if i remove the bulb and put it back in, it works.......for a couple days, then goes back out again. Nothing wrong with the bulb itself. I even changed it to be sure. Same thing. Super annoying since im a full time lyft driver and im ALWAYS on the road at night. Id rather not end up with a ticket lol.
You might want to try and use some electronics part cleaner you can find at most auto supply stores. Sometimes the socket may look clean to the naked eye, but may have some oxidation that can cause the issues you are dealing with. Cheap fix if it works,..................Good Luck
pimperell is offline  
post #3 of 3 Old 11-01-2016, 11:48 PM
Level III Member
 
Join Date: Sep 2011
Posts: 105
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Feedback Score: 0 reviews
I believe the contacts in the socket are not making good connection. With the lights off and the bulb out of the socket bend the connectors up or away from the side so that when the bulb is inserted the contacts make harder contact with the bulb. Do not bend the contacts too much.

Frank 2009 Versa S sedan with MT-6 and 80K miles
Francesco is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome