Dash Instrument Cluster Odometer LCD - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-21-2017, 10:36 PM Thread Starter
Level I Member
 
Join Date: Nov 2016
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Dash Instrument Cluster Odometer LCD

Hey all. I removed my cluster to see what leds I could put in there, and found no where to remove the old ones on back, it's just a circuit board with 3 white connectors where the needles are positioned. Now the odometer lcd is showing scrambled and faded characters. Does this mean to have it flashed to match the ECU? Or is it just fried somehow? It is the same cluster removed and installed, I did have to disconnect neg on the battery when remove/install.
2009 Versa SL 1.8 Hatch with ABS/CVT AT
Daeda1864 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-22-2017, 08:12 AM
Level VI Member
 
Join Date: Jan 2017
Posts: 846
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Feedback Score: 0 reviews
Might check how well you reattached the battery cable. You dang sure better have had it disconnected or risk poofing something.

Could there be a cluster fuse there somewhere?

Interconnected electronics, you really gotta love 'em......................

Last edited by amc49; 01-22-2017 at 08:15 AM.
amc49 is offline  
post #3 of 5 Old 01-22-2017, 12:13 PM
Level V Member
 
Join Date: Sep 2012
Location: New Jersey
Posts: 647
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Daeda1864 View Post
Hey all. I removed my cluster to see what leds I could put in there, and found no where to remove the old ones on back, it's just a circuit board with 3 white connectors where the needles are positioned. Now the odometer lcd is showing scrambled and faded characters. Does this mean to have it flashed to match the ECU? Or is it just fried somehow? It is the same cluster removed and installed, I did have to disconnect neg on the battery when remove/install.
2009 Versa SL 1.8 Hatch with ABS/CVT AT
If it is the Odometer, it could be some type of deterrent to stop the tampering of the true mileage of the car and may have to be reset by the dealer.............just a guess on my part.
pimperell is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 01-22-2017, 03:33 PM
Level VI Member
 
Join Date: Oct 2016
Location: Central, VA
Posts: 1,105
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 167 Post(s)
Feedback Score: 0 reviews
On one hand I was going to say you did not put it back together correctly. Usually in that case people mix up the pieces of plastic so the screen is inverted white on black display or upside down. Could be you got some loose contacts. If you put pressure on it does it read better?

I guess there is always the junk yard or ebay for a new dash. Im sure the miles is kept in the eco somewhere vs the dash like with mechanical odos.
Cobb is offline  
post #5 of 5 Old 02-17-2017, 06:27 PM Thread Starter
Level I Member
 
Join Date: Nov 2016
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Dash Cluster Replaced

Ok. Got it done. Got great condition unit, and they programmed the mileage for me at extra cost, but worth it. On ebay instrumentclusterstore.
Daeda1864 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome