Turn signal trouble - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-25-2017, 08:07 AM Thread Starter
New Member
 
Join Date: Feb 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Turn signal trouble

I have a 2008 Nissan Versa hatch back.

My problem is I just got this car and the turn signal indicator was flashing rapidly so I replaced the one that was need. Front passenger side. Put a new bulb in and it still doesn't light up and the indicator inside is still flashing rapidly.

Is there a turn signal fuse ? And where ?
Is there something that I'm missing here ?

I'm new to this have a newer car all my cars were older, but it's hard for me to take it to a dealer because I just want to do it myself.

Thanks
Hondo Vallejo is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-25-2017, 11:56 AM
Level VI Member
 
Join Date: Jan 2017
Posts: 825
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 84 Post(s)
Feedback Score: 0 reviews
Usually no fuse for only one position. Likely your bulb socket or wiring to it bad. One thing that can happen on older ones is relaxing of the bulb socket contacts from long term heat, try taking something to get under/behind the contacts and pry them in toward the center more to make the airspace in between them smaller, it then gets better contact to possibly work. They heat long enough and they move apart and sometimes don't make contact.
amc49 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome