Versa Slave bleeding issue - Page 2 - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 11 Old 04-11-2017, 02:11 PM
New Member
 
Join Date: Apr 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
In the middle of doing clutch replacement got to bleeding and the pedal stopped moving became solid. Rebleed same thing, after taking old parts and referencing how I had installed them, found out that the OEM Versa clutch disk flat side goes toward the/transmission! On the old disk it tells you what side goes where, the instruction that came were even wrong. This makes slave not even reach the fingers of pressure plate.
On the 07 Versa there is no bleedscrew where the slave meets the master is a lil spout in the line on top of the connector, it has 2 seated position release the clip pull back replace clip, connect clear hose to spout and bleed as normal.
SecurityFTLB is offline  
Sponsored Links
Advertisement
 
Reply

Tags
bleeding , clutch , hard pedal , master , slave

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome