High RPM - revving up - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-23-2017, 07:38 PM Thread Starter
New Member
 
Join Date: Sep 2017
Location: Texas
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Garage
Feedback Score: 0 reviews
High RPM - revving up

I have an 07 Versa hatchback. As of the last month, the RPM has run high when idle. My dad said it's starting as high as 2000 right now. It drops and then revs back up, over and over. Once put in to drive, the RPM drops. When the AC is cut on, it drops even lower. While driving, the RPM has even dropped to 0 before jumping back up. About a year ago, the RPM would drop to 0 and the car would cut off WHILE DRIVING! We took the car to 2 separate Nissan dealers, one of which, kept the car for over 2 weeks and found nothing wrong! After a couple days of having it back home, the car stopped cutting off all of a sudden. Now, suddenly it's back to having issues. My dad is a mechanic and has been working on it for a couple weeks. He's at a total loss as to what is causing this.

Has anyone else had this issue?? I had hoped to keep the car since it is paid off and I don't want a car payment. Lol. But, if we can't drive it safely, I may need to look into a new vehicle.

2007 Nissan Versa hatchback
Bought used 2015
No official name, but often referred to as "Baby".
bigdreamer121 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-24-2017, 12:20 PM
Level V Member
 
Join Date: Sep 2012
Location: New Jersey
Posts: 665
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by bigdreamer121 View Post
I have an 07 Versa hatchback. As of the last month, the RPM has run high when idle. My dad said it's starting as high as 2000 right now. It drops and then revs back up, over and over. Once put in to drive, the RPM drops. When the AC is cut on, it drops even lower. While driving, the RPM has even dropped to 0 before jumping back up. About a year ago, the RPM would drop to 0 and the car would cut off WHILE DRIVING! We took the car to 2 separate Nissan dealers, one of which, kept the car for over 2 weeks and found nothing wrong! After a couple days of having it back home, the car stopped cutting off all of a sudden. Now, suddenly it's back to having issues. My dad is a mechanic and has been working on it for a couple weeks. He's at a total loss as to what is causing this.

Has anyone else had this issue?? I had hoped to keep the car since it is paid off and I don't want a car payment. Lol. But, if we can't drive it safely, I may need to look into a new vehicle.


Dirty injectors, dirty fuel filter, dirty egr, pcv valve, failing O2 sensors, vacuum leak....and add some dry gas, and Lucas Fuel Injector Cleaner. Don't know if you fill up at the same gas station all the time, but you may be picking up some bad fuel.
pimperell is offline  
post #3 of 3 Old 09-25-2017, 12:42 AM
Level VI Member
 
Join Date: Oct 2016
Location: Central, VA
Posts: 1,105
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 167 Post(s)
Feedback Score: 0 reviews
Sounds like either an air leak somewhere or the itac(SP?) idle servo is acting up. What is the AFR? Any codes?

What if you spray the hoses under the hook with wd40, does it get better or worse?
Cobb is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome