2011 Nissan Versa no electrical power - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-07-2017, 09:56 PM Thread Starter
New Member
 
Join Date: Oct 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
2011 Nissan Versa no electrical power

Hi. My 2011 Versa has been sitting in the garage for a few months. I just went to start it and I get no electrical. Tried to jump start it and still no joy with cables hooked up. Any ideas?
Johnwestbay is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-09-2017, 01:55 PM
Level V Member
 
Join Date: Sep 2012
Location: New Jersey
Posts: 647
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Johnwestbay View Post
Hi. My 2011 Versa has been sitting in the garage for a few months. I just went to start it and I get no electrical. Tried to jump start it and still no joy with cables hooked up. Any ideas?
If the car was running when it was put in the garage for a few months, and now you have "no electrical ", I would suggest that you check your battery connections to insure that they are not corroded and are making good contact with the battery posts. When trying to jump start the engine, you might want to leave the jumper cables connected for a few minutes before trying to start the car. Sometimes, if the in car battery has been totally drained for some reason, it takes a few minutes before you can start the car even with a jump. Another possibility could be the in car battery itself. If it is physically damaged like a bad plate, it will be difficult to start the vehicle.
pimperell is offline  
post #3 of 4 Old 10-09-2017, 02:48 PM
Level VI Member
 
Join Date: Oct 2016
Location: Central, VA
Posts: 1,105
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 167 Post(s)
Feedback Score: 0 reviews
So, do you hear a chime when you insert keys in ignition? Do the head lamps, parking lamps work? What about horn? Do the idiot lights work when you turn the key? When you turn to start does the engine crank, do you hear a click or clicking, or nothing at all?

Is it completely dead?

Can you check or charge the battery? Better yet take the battery to an auto store to get checked?
Cobb is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 10-24-2017, 01:35 AM
New Member
 
Join Date: Oct 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Please help I am having similar issues, but mine went dead over the weekend. Checked battery and connection, fusible link, yes the door beeps when keys put in. But only light im getting is flashing red car with key. No headlights also
Theflynnster is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome