'09 1.8 CTV, Replace Crankshaft Pos Sensor help pls - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 1Likes
  • 1 Post By amc49
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-02-2019, 01:02 AM Thread Starter
New Member
 
Join Date: Jan 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
'09 1.8 CTV, Replace Crankshaft Pos Sensor help pls

Hey everyone,
First time, long time...

Can anyone advise or direct me to info to help replace 09 Versa Crankshaft Position Sensor? The factory service manual advises how I can test functionality. Haynes repair manual only shows a 2" x 2" picture of the sensor location. Alldatadiy charges $30 but their repair procedure examples don't look like they will help, so I don't want to pay for the same info that is free in the fsm. I removed battery, air inlet duct, throttle body & connecting hose attached to air intake housing, all to try and get to where Nissan's engine diagram shows the sensor is. However, I can't even see the sensor's cover bracket. Should I be trying to approach from under the car? Anyone with experience or '07-'14 Crankshaft Position Sensor knowledge, who can help, your input would be greatly appreciated.

Thanks in advance for your time and attention,
Clay
clayworks is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-02-2019, 04:54 AM
Level VI Member
 
Join Date: Jan 2017
Posts: 823
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 84 Post(s)
Feedback Score: 0 reviews
The engine changed at '12.

The sensor is on back of engine (firewall side) down low on block although manual says oil pan. Close to trans end of motor. There is a sheetmetal formed cover over it. Go under car to get to it.
pimperell likes this.
amc49 is offline  
post #3 of 4 Old 01-03-2019, 01:31 AM Thread Starter
New Member
 
Join Date: Jan 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by amc49 View Post
The engine changed at '12.

The sensor is on back of engine (firewall side) down low on block although manual says oil pan. Close to trans end of motor. There is a sheetmetal formed cover over it. Go under car to get to it.
Thanks for the advice. Does anyone have an idea of what I will need to move/remove to access the sheetmetal cover while underneath? I know the space is really tight.
clayworks is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 01-03-2019, 01:44 AM
Level VI Member
 
Join Date: Jan 2017
Posts: 823
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 84 Post(s)
Feedback Score: 0 reviews
Not a clue, haven't done it yet.
amc49 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome