May be having fuel problem - Nissan Versa Forums
General Technical & Electrical Anything not in a specific group, discuss here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-01-2012, 01:13 PM Thread Starter
New Member
 
hobbsg's Avatar
 
Join Date: Aug 2012
Location: Atlanta
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
May be having fuel problem

On my way from Tennessee to Atlanta, right after we filled up w/gas, my Versa cut off and we had to re-start it. Then, while travelling up a mountain, it started jerking as i pressed the gas and the engine light came on. It worked fine Monday but then Tuesday, after the engine light went off, it started happening again. It feels like a fuel problem to me but i'm a car idiot. do i just need a new fuel filter or a fuel cleaner? Any experience would help. it's a 2011 with 40,000 miles, so i hope it's nothing major. Thanks!
hobbsg is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-01-2012, 02:34 PM
Level III Member
 
Royzacsdad's Avatar
 
Join Date: Jun 2012
Location: Wayne, Oklahoma
Posts: 177
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Garage
Feedback Score: 0 reviews
I know this sounds silly, but did you check to make sure your gas cap is on good? Also you may have got some bad gas. Both of these have happened to me in the past on different vehicles.
Royzacsdad is offline  
post #3 of 5 Old 08-08-2012, 12:29 PM Thread Starter
New Member
 
hobbsg's Avatar
 
Join Date: Aug 2012
Location: Atlanta
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Actually, that's not silly. It says to check the gas cap in the owner's manual. i thought it might be bad gas, too. Everything's been fine until yesterday it did that dang cut off thing again! I just don't want to get ripped off by the dealership or a repair shop. I may have to just bite the bullet and bring it in. Thanks for the response.
hobbsg is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 11-27-2012, 03:02 PM
New Member
 
Join Date: Nov 2012
Location: Jamaica
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hi was your problem resolved?if yes what was it?
Tida is offline  
post #5 of 5 Old 11-27-2012, 04:31 PM
Level V Member
 
Join Date: Sep 2012
Location: USA
Posts: 440
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Feedback Score: 0 reviews
Could have been bad gas. I would have called the gas station and see if they had any problems with water in the gas. In addition, I would have put 2 bottles of HEET in the tank in case there is water in the gas.
Versa12 is offline  
Reply

Tags
2011 , filter , fuel

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome