2010 versa brake warning light - Nissan Versa Forums
General Versa Discussion Everything about Versa's that does not fit in another forum

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 Old 12-19-2012, 02:12 AM Thread Starter
New Member
 
Join Date: Dec 2012
Location: lanesville, IN
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2010 versa brake warning light

hello all, my name is rusty and i am new to this site. i have a 2010 versa. it's a great family car. i have twin girls so it is plenty big enough and get's great mpg's. today when my wife was on her way home the brake warning light. the one that is the ! in a circle surrounded by the ( ). i checked the manual to see what to do and it said to check the fluid. i did and filled it up and the light is still on. how long will it take for the light to go off? thanks and have a great day.
rustybobblehead is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 12-19-2012, 02:29 AM
Member
 
Join Date: Mar 2009
Location: Denver, CO
Posts: 3,417
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
(!) means you need to put more air in your tires. Make sure they're above 33psi and drive around for 15 minutes and the indicator will go away.
Hschlick84 is offline  
post #3 of 14 Old 12-19-2012, 02:30 AM Thread Starter
New Member
 
Join Date: Dec 2012
Location: lanesville, IN
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
but it doesn't look like the low on psi indicator. it looks like the brake warning light. i will try that tomarrow with the tires though. thanks.
rustybobblehead is offline  
Sponsored Links
Advertisement
 
post #4 of 14 Old 12-19-2012, 02:45 AM
Level VI Member
 
hemifan87's Avatar
 
Join Date: Sep 2010
Location: Norfolk, VA
Posts: 1,965
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
Send a message via AIM to hemifan87 Send a message via Skype™ to hemifan87
can you post a pic and what color is the light

2009 Nissan Versa DD project Black Widow
1987 Nissan 200sx new weekend project

project Black Widow
https://www.nissanversaforums.com/showthread.php?t=2313
Project 200sx
https://www.nissanversaforums.com/non...w-old-car.html
My Facebook Versa page if your in Virginia come join us
http://www.facebook.com/#!/pages/Ver...66480763434590
I'm now on Instagram #hemifan87

ΜΟΛΩΝ ΛΑΒΕ
hemifan87 is offline  
post #5 of 14 Old 12-19-2012, 11:25 AM Thread Starter
New Member
 
Join Date: Dec 2012
Location: lanesville, IN
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
No sorry. All I have is a kindle fire. Lol. Its the one right below the speedo. I dunno if some versa came out with no tach so the lights would be different. But mine does have the tach. If that helps out any.
rustybobblehead is offline  
post #6 of 14 Old 12-19-2012, 12:33 PM
Level IV Member
 
ShyGuy's Avatar
 
Join Date: Dec 2012
Location: Houston, TX
Posts: 302
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
Feedback Score: 1 reviews
Does it look like this?
Attached Thumbnails
Click image for larger version

Name:	IMG_0092[1].jpg
Views:	5664
Size:	80.0 KB
ID:	1182  
ShyGuy is offline  
post #7 of 14 Old 12-19-2012, 12:35 PM
Level V Member
 
Join Date: Sep 2012
Location: New Jersey
Posts: 653
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by rustybobblehead View Post
hello all, my name is rusty and i am new to this site. i have a 2010 versa. it's a great family car. i have twin girls so it is plenty big enough and get's great mpg's. today when my wife was on her way home the brake warning light. the one that is the ! in a circle surrounded by the ( ). i checked the manual to see what to do and it said to check the fluid. i did and filled it up and the light is still on. how long will it take for the light to go off? thanks and have a great day.
As a prior poster mentioned, the light you describe would be the tire pressure warning. According to your manual the "Brake Warning" indicator should have an "ABS" in the circle, or a Square design with the letters "ABS" in it. Also make sure your emergency break is fully released. Good luck
pimperell is offline  
post #8 of 14 Old 12-19-2012, 02:51 PM Thread Starter
New Member
 
Join Date: Dec 2012
Location: lanesville, IN
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
to shyguy. yes, yes it is. so what should i do now?
rustybobblehead is offline  
post #9 of 14 Old 12-19-2012, 02:54 PM
Level IV Member
 
ShyGuy's Avatar
 
Join Date: Dec 2012
Location: Houston, TX
Posts: 302
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
Feedback Score: 1 reviews
That is actually a TPMS (Tire Pressure Monitor System/Sensor) light, as state above. It is actually the light for either over or under inflated tires. Or if you're in my situation the sensor is broken and it is constantly on until it is replaced. Try inflating your tire to the appropriate pressure and drive for around 15-20 minutes to see if the light goes off.
ShyGuy is offline  
post #10 of 14 Old 12-19-2012, 02:56 PM
Administrator
 
JoshG's Avatar
 
Join Date: Apr 2010
Location: Tampa, FL
Posts: 4,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 90 Post(s)
Feedback Score: 0 reviews
Make sure your tires are at around 33PSI(if not, fill them up to there), drive for 10min~ and it'll go away. Tires get low during the winter so it's going to happen quite a few times.

2010 NISSAN VERSA 1.6
1991 MAZDA B2600i
JoshG is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome