Radio Swap Versa Note 2014 - Source and volume control not working - Nissan Versa Forums
I.C.E. - In Car Entertainment Discuss about audio, video, navigation, security and wiring here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-11-2019, 08:05 PM Thread Starter
New Member
 
Join Date: Aug 2019
Location: Quebec
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Unhappy Radio Swap Versa Note 2014 - Source and volume control not working

Hi,
I hope that someone can help me understand this strange situation. I tough that i could do i radio Swap of the basic factory radio to the one with the Nissan factory radio but with the 5 inches screen.
Since my 2014 versa did not have a backup camera, it did not bother me not to have it a the new radio unit, but i said to myself that it would be nice to have a little upgrade of my radio Unit. So i swapped the radio and found out that one of the cable could not be attached to the new radio, I tough, oh well , i will just see what`s working so i gave it a try. I've turned on the the ignition to on. The radio came alive, every thing looks ok, but i quickly realized that the SOURCE,SELECT and VOLUME buttons on the steering wheel were not working. I tough it might be the cable that i did not plugged. So after a few minutes of verification i've decided to put back the original radio in place. To my surprise the SOURCE, SELECT and VOLUME buttons were not working either...
Is there some thing i can verify to make them work again? Could it be related to the new radio and some kind of a mismatched pin connection and when i plugged it and blew the steering wheel button module. I did not touched anything else. Call button Phone to Bluetooth radio is working.

Thank you in advance for your answers.

Last edited by Daniel Larocque; 08-12-2019 at 05:54 PM.
Daniel Larocque is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Today, 03:24 PM Thread Starter
New Member
 
Join Date: Aug 2019
Location: Quebec
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Update:
Finally i had to bring the car to the Nissan repair service. They had to change the left steering wheel module (The one with the buttons that were not working).
Since i have an extended warranty for my Versa, i was not charged for the replacement. On the other side i'm not sure that they had to change the module. For some reason i had to pickup my car to go back to home because they did not have the part in stock and there was another fix to be done on my car so they asked me to come back the next morning. To my surprise all the buttons were working well. When i brought back my car the next day i said to the service manager that everything was back to normal. My assumption is, that they unplugged the cable attached to the module or the radio, put it back on and reset the connection. Other option, is that they unplugged the wire from the battery and by reattaching it, it reset the module. I'm not an expert but i think it could have an effect on resolving the problem. Because the part was under warranty the manager decided to replace it just to avoid any other problem.
Daniel Larocque is offline  
Reply




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome