this is my engine - Nissan Versa Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 10-23-2010, 04:11 AM Thread Starter
Level VI Member
 
BluV3R18's Avatar
 
Join Date: Aug 2010
Location: Knoxville, TN
Posts: 2,364
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
this is my engine

BluV3R18 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-23-2010, 07:35 AM
Level III Member
 
Join Date: Jul 2010
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
wow... I didn't know that Nissan had a contract to use cummins diesels. I would take it in to have it fixed, mine smells a little like coolant but I can't find it anywhere. It's not leaking, it's not using any, I just don't know.
PIMking is offline  
post #3 of 6 Old 10-23-2010, 04:34 PM Thread Starter
Level VI Member
 
BluV3R18's Avatar
 
Join Date: Aug 2010
Location: Knoxville, TN
Posts: 2,364
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by PIMking View Post
wow... I didn't know that Nissan had a contract to use cummins diesels. I would take it in to have it fixed, mine smells a little like coolant but I can't find it anywhere. It's not leaking, it's not using any, I just don't know.

is yours more quiet?

btw
if yours smells like coolant then you may have a small leak somewhere.
check hoses and coolant container.
I had a cavalier that it smelled like coolant after I drove and it was a bracket leaking from the water pump to the heater core but this is a versa not a cavalier.
BluV3R18 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 10-23-2010, 07:30 PM
Level III Member
 
Join Date: Jul 2010
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yes mine is quiet,

I'm not loosing coolant, I've drove the car 3k miles in the last two weekends and I marked the overflow jug and it hasn't moved. So I don't know what the hell is going on.
PIMking is offline  
post #5 of 6 Old 10-23-2010, 09:24 PM Thread Starter
Level VI Member
 
BluV3R18's Avatar
 
Join Date: Aug 2010
Location: Knoxville, TN
Posts: 2,364
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by PIMking View Post
yes mine is quiet
it is very quiet where I was so my camera picks up any sound and doubles it.
sometimes I can hear myself breath on the videos so I try not to breath so close to it. the engine is not knocking, missing, shaking, leaking or anything and I can't hear the engine running when I'm inside.
BluV3R18 is offline  
post #6 of 6 Old 10-23-2010, 11:00 PM
Level VI Member
 
APLPIX's Avatar
 
Join Date: Feb 2010
Location: Brampton, Ontario, Canada
Posts: 1,100
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
If its a cold start/warming up, it is gonna be noisy until everything is normal running temp.
APLPIX is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome