Nissan Versa Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello! I'm hoping someone here can help me diagnose my girlfriend's 09 versa.

1.6L automatic.

Most of the time the car starts, runs and drives perfectly. She has maintained it well and the car is in good shape. The car is not throwing any codes and I haven't found any way to "trigger" the issue. It just happens randomly.

I'll describe the best I can.

It seams to be the worst from a stop. If your at a complete stop and you go to accelerate nothing happens. Take foot off brake and the car moves at the speed it does at idle. When you step on the gas nothing happens. The tach doesn't move. It doesn't make and noise. Just nothing. After a little wile it just works all the sudden and you get a surge of power equal to how ever much throttle you are giving it.

Some things I have noticed. When it is acting up, once you start moving it drives alright. If your at part throttle it kinda has a bit of a stumble to it. If you punch it the car responds properly. It kinda feels like a dying or improperly calibrated throttle position sensor (I'm sorry if that's the wrong lingo, I'm not familiar with nissan)
As soon as you come to a stop it does it again. Step on gas, nothing... 1, 2, 3, 6, 7, BANG it goes...

Sometimes putting it in park then back in gear solves it. Sometimes it doesn't.

Usually if I put it in park, shut it off, start it back up it fixes it.

Almost all the time the car runs perfectly. Then randomly it just doesn't accelerate from a stop. It's been really dangerous a few times. Go to turn out into traffic and your just stuck there creeping thru an intersection...

Where do I start? It feels to me like a bad sensor. Either a sensor on the gas pedal or maybe her throttle body is dying? It feels like a failing drive by wire system. Is there a procedure to check or re-calibrate her throttle body?

Really appreciate any advice I can get. I am a pretty confident backyard diy mechanic and I'd really like to help her with this.

Thanks.
 

·
Registered
Joined
·
476 Posts
Has the throttle body ever been cleaned?
I would do that and to a relearn on the throttle body.
 
  • Like
Reactions: pimperell

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I doubt it. She is not particularly car savvy. I don't see anything in her service records that shows work done anywhere around the TB.

Is there a link to a post here on how I would "re learn the TB" ?

From my research it looks like this is related to the brake light circuit. Ive found people saying they had similar problems after getting a brake job and also people who installed an incorrect brake light. It sounds like if the ecu sees a signal from the pedal it will cut throttle.

She has not had recent brake work done but I might fiddle with the switch on her brake pedal.
 
1 - 3 of 3 Posts
Top