Nissan Versa Forums banner

21 - 39 of 39 Posts

·
Registered
Joined
·
2,364 Posts
How is the oil level on it and when was the last time it was changed?

if there's no money and you need transportation sell something to get cash and get the car fixed. that way you don't have to borrow any money
 

·
Registered
Joined
·
76 Posts
Discussion Starter #22
How is the oil level on it and when was the last time it was changed?

if there's no money and you need transportation sell something to get cash and get the car fixed. that way you don't have to borrow any money
changed 5k ago, my dad put in two quarts before it shut off.

here is a quoate again from saabcentral, his subaru did the same thing

Hey, This is what it sounds like when you have a blown bearing and your piston is hitting the head.

(This is my subaru on its first engine)

http://www.youtube.com/watch?v=6VWGBG4MIC4

Pretty sure you have the exact same problem.. Except sounds like yours is also misfiring. Mine was actually firing fine and all so no lights came on the dash. But I bet much longer and it would have really damaged something and started misfiring.
 

·
Registered
Joined
·
1,285 Posts
THE SAME EXACT THING HAPPENED TO ME!

That sucks... really bad.... after that nissan said i needed a new engine and wanted me to buy a new motor for $4k! I said no way and got the MR20 for $850 at a junk yard.

heres my video

 

·
Registered
Joined
·
2,364 Posts
did it shut off the same day he added the 2Qts of Oil?

I traded my subaru for the Versa, it was a Legacy L 2.2 and it had over 200,000 miles on and the tranny needed to be rebuilt and I didn't want to spend 3,000.00 on a car that was falling apart, plus it had electrical problems.

I bought it because I'm a cheapskate and didn't want to spend too much, but I think I learned my lesson and realized that if I go too cheap, it will cost more in the long run.
 

·
Registered
Joined
·
2,364 Posts
Well number 3 is coming, where i give it some gas

stepping on the gas

STEPPING ON THE GAS
what were those lights on the dash?

it is knocking pretty bad unless the timing chain came off track or something
I hear lifters and valves knocking louder than normal

Here's mine, and this is what it sounds like when is cold, that's why the idle sounds higher but after it warms up, it stills sounds about the same lol
 

·
Registered
Joined
·
1,100 Posts
What oil have you been using? If its cheap stuff, sludge can build up and restrict flow through the oil pump making less oil feed the valvetrain. It sounds like valve knock on idle and piston slap/rod knock when you gas it.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #28
What oil have you been using? If its cheap stuff, sludge can build up and restrict flow through the oil pump making less oil feed the valvetrain. It sounds like valve knock on idle and piston slap/rod knock when you gas it.
not sure, it's my parents car. they usually are a little late on oil changes not bad, but a mechanic does it, and my dad just got the oil at a gas station
 

·
Registered
Joined
·
76 Posts
Discussion Starter #29
did it shut off the same day he added the 2Qts of Oil?

I traded my subaru for the Versa, it was a Legacy L 2.2 and it had over 200,000 miles on and the tranny needed to be rebuilt and I didn't want to spend 3,000.00 on a car that was falling apart, plus it had electrical problems.

I bought it because I'm a cheapskate and didn't want to spend too much, but I think I learned my lesson and realized that if I go too cheap, it will cost more in the long run.
yeah i think he said 24 miles before home he put in the qts of oil
 

·
Registered
Joined
·
76 Posts
Discussion Starter #30
what were those lights on the dash?

it is knocking pretty bad unless the timing chain came off track or something
I hear lifters and valves knocking louder than normal

Here's mine, and this is what it sounds like when is cold, that's why the idle sounds higher but after it warms up, it stills sounds about the same lol
that sounds like the normal ticking in the versa's

but like i mentioned we have a lot of options
 

·
Registered
Joined
·
1,285 Posts
i use mobil 1 extended but MR motors eat up oil. i was told that my piston melted and a rod broke or something.
 

·
Registered
Joined
·
1,285 Posts
just to throw out some more info, mine was a 2007 motor as well, and it took a shit on me at about 66k miles
 

·
Registered
Joined
·
76 Posts
Discussion Starter #37
my only guess is late oil changes, my parnets sometimes went 5-6k with out a oil change.

and heavy car use, um the ticking was always there
 

·
Registered
Joined
·
76 Posts
Discussion Starter #39
yeah a little bit, they got em usualy on time, just sometimes they went over.

and highway miles by far, my dad works 45 mins away all highway, and recently he would get home and my mom would take the car and go 20 miles,

car has 89,250 i think
 
21 - 39 of 39 Posts
Top