Nissan Versa Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I'm new to the forum i hope this is correct area to ask about cvt transmission. 75,000 miles don't know if transmission has been serviced. Transmission functions fine for awhile especially at highway speeds then when slowing down sush as stop and go the transmission slips sometimes will almost not go then with further pressure on accelerator is takes off and will run fine for awile
 

·
Banned
Joined
·
455 Posts
well the cvt is still under warrenty!!! so take it too a dealer...idk when the cvt needs to be flushed or whatever but i do know its far from cheap...just cause it uses a special kind of fluild and is alot of money to make and what knot. the warrenty on the cvt is what 10 years/ 100,000 miles on it now?
 

·
Registered
Joined
·
377 Posts
Will keep you updated on what happens with mine. They're looking at it more extensively tomorrow and might replace. Slipping and warning codes.
 

·
Registered
Joined
·
2,466 Posts
Yes Nissan very picky which tranny fluid goes in. My Altima has a sticker for it under the hood. Get it looked at quick, that's what the extended free factory warranty is for:)Welcome Will!
 

·
Registered
Joined
·
407 Posts
Could be fluid change needed. Yes, fluid should be Nissan's and it is about $25 per Litre in Canada, and it needs a lot so about $300 to change here.

Also could be malfunctioning and slipping into emergency road (like if the CVT overheats), then it stops itself from responding to accelerator inputs and not move for awhile. Not sure if this could be part of your problem.

Good Luck!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top