Nissan Versa Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
2009 Horn not working - Fixed

2009 Versa S.
my daughter called and said her horn stopped working when she locks the car and does not work if she pushes on the horn from steering wheel.
I checked the 10A fuse and it's good.
I replaced the Relay so it should be good
When I push the lock button from the remote I can hear the relay clicking, is that good?

what else could it be. As far as I can tell all other electronics work on the car.

thanks
Dan
 

·
Registered
Joined
·
527 Posts
Maybe the horn itself has failed? Not sure if the horn is easily accessible but if so, check if power is getting to the horn using a test light or VOM.
 

·
Registered
Joined
·
84 Posts
Try this: on the key fob, press the lock and unlock buttons together until the car turn signals turn on.

Basically you can program nissans to have the horn come on or not when you press the key fob.
 

·
Registered
Joined
·
527 Posts
Try this: on the key fob, press the lock and unlock buttons together until the car turn signals turn on.

Basically you can program nissans to have the horn come on or not when you press the key fob.
Red, I don't think this is just a key fob issue. The horn does not work even when the horn button is pushed on the steering wheel.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks for the replies. I found the issue. one of the wires at the horn was not attached well. To be honest it was just a stripped wire that had black tape on it from the previous owner. I went to parts store and picked up some connectors, added that and she now has a working horn.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top