Nissan Versa Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
The radiator fan does not seem to want to come on, on its own. The fan motor works fine if I bypass it straight to the battery; super fast. On the fan shroud there are two plugs. Neither plug has power going to it. I am assuming that the one going to the metal box (relay?) on the back should have power coming to it (blue and yellow wire). It does not. The other plug appears to go directly to the fan motor (yellow and black wires) it also does not have power. I cannot figure this out.

Where do I go from here? I have checked all the regular fuses I can and they all seem to be fine. I do not know how to check a power relay or which one it might be.
Any help would be appreciated.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
okay. i have a temporary fix. I disconnected the thermostat temperature sensor wire and the radiator fan runs the whole time the car is on. If I re-connect it then the fan stops. Sensor must be bad. Of course the check engine light comes on if I do this but at least the car won't overheat.
 

·
Registered
Joined
·
1,028 Posts
Fans quit working 100% of the time 25 years ago, they only work when needed if A/C is off and temp is high enough to do so. A/C being on may make them come on all the time, depends on the car software. I can go literally almost all winter with fans never coming on at all on some of my cars.

Disconnecting the temp sensor just means you have done just that, almost all cars default to fan(s) on with that done. The fan wiring is likely way more complicated than you describe there as well. You need an exact year electrical schematic there.
 
1 - 3 of 3 Posts
Top