Nissan Versa Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Issue:

1. Rear wiper fluid nozzle does not eject liquid. Doesn't seem to be a blockage near the final exit area of the nozzle, tried to check with a pin? Front wipers and liquid are fine, rear only is the issue.
2. Rear Wiper doesn't work "properly" by that I mean, it seems to only wipe inverted to what it should be wiping (instead of wiping West, North, East, it wipes East, South, West), and rarely, it works on its own in the proper position for a short period of time.
3. back wiper itself seems to be deteriorating and will be replaced but that's not as important as the first two points right now.

How do I fix this on my own? What should be replaced?
 

·
Registered
Joined
·
764 Posts
Issue:

1. Rear wiper fluid nozzle does not eject liquid. Doesn't seem to be a blockage near the final exit area of the nozzle, tried to check with a pin? Front wipers and liquid are fine, rear only is the issue.
2. Rear Wiper doesn't work "properly" by that I mean, it seems to only wipe inverted to what it should be wiping (instead of wiping West, North, East, it wipes East, South, West), and rarely, it works on its own in the proper position for a short period of time.
3. back wiper itself seems to be deteriorating and will be replaced but that's not as important as the first two points right now.

How do I fix this on my own? What should be replaced?
1- Check the washer pump. On fluid bottle at bottom. Also check fuse 4 in fusebox by left knee.

2- Motor assembly may be bad. To get at it, you must remove hatch cover.
WARNING!!! Hatch cover IS very fragile and will break very easily! If you have a pull-a-part nearby, go and practice on a few so you know what to do.

3- Can be done when fixing 2
 
  • Like
Reactions: Ecate

·
Registered
Joined
·
884 Posts
Issue:

1. Rear wiper fluid nozzle does not eject liquid. Doesn't seem to be a blockage near the final exit area of the nozzle, tried to check with a pin? Front wipers and liquid are fine, rear only is the issue.
2. Rear Wiper doesn't work "properly" by that I mean, it seems to only wipe inverted to what it should be wiping (instead of wiping West, North, East, it wipes East, South, West), and rarely, it works on its own in the proper position for a short period of time.
3. back wiper itself seems to be deteriorating and will be replaced but that's not as important as the first two points right now.

How do I fix this on my own? What should be replaced?
What you might try to free a blockage is a piece of monofilament 10 pound test fishing line. That will be better than using a pin to clear a blockage if there is one. Good luck!!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
I tried clearing a blockage that way and it didn't seem to work.

I'm wondering if the cable inside had got loose, but I haven't got around to taking the back hatch cover off yet...
 
1 - 4 of 4 Posts
Top