Nissan Versa Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi all,
I have an '07 SL hatchback that I bought new and love!
In the last couple weeks, I've noticed that my 6-disc changer would occasionally display "Mechanism Err", then "Push Eject".
I could always kick out the disc and reload it, and all would be fine for a while.
Today, however, I'm getting that same error, but I can no longer eject any discs, nor will anything play from the CD deck. I've tried ejecting all the discs by holding the eject button, as well as holding eject while turning on the unit, with no success.
If I listen closely, I can hear the unit try to pick up the disc to eject, then it sounds like the 'wheels' are slipping. I hear a motor running, but nothing happens.
It tries several times, then either gives the same error again or just switches to radio.
Anyone have any idea where to start diagnosing this?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I agree, it sounds like the ejector isn't gaining traction on the disc.
Anyone know the procedure for removing the head unit without jacking up the airbag?
I had a small powered subwoofer installed back when I first bought the car, and it messed up my airbag sensor.
The dealership reset it for me, but they said not to mess with the head unit anymore, or they would charge me to fix it next time.
I'd rather avoid that headache if possible!

-Elmojo

P.S.: I use mp3 discs because I get over a hundred songs per disc and don't have to have my ipod plugged into the unit all the time, screaming *steal me!*.
Also, the sound is better from the CD vs the Aux-in jack.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top