Nissan Versa Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Hi,

I have a 2009 nissan tiida with 120000km on it. recently i asked the shop to change the pressure sensor on a/c line high side since i probably though the problem of the a/c not cycling is the sensor. It was working for a hour so i decided to go and assumed it was all fixed. After 2 hours my a/c went out, blowing hot air, so I checked that my a/c clutch is not engaged. during this 2 hours I blew and replace 2 fuses (10a under the streering wheel) for the a/c. I brought it back to the garage, they did some test on r-134a levels and it was fine, and since i have little knowledge of my cars electrical (through reading some manuals) I decided to test the harness of the pressure sensor. I jumped wires 1 and 2 of the pressure sensor side but the only thing that ran is the fan in front of the condenser. The clutch wont engage at all (usually it will engage coz i have tried it before) . I also checked the wires from the end of the harness to the ecm side and it has continuity and voltage.



So i though maybe the problem is with the clutch itself so I did the active test and the clutch engages as well as all the other checks are fine. That means the IPDM is ok. However, when i checked active test page i found this?


YES
• BCM signal input circuit
• CAN communication signal between BCM and ECM
• CAN communication signal between ECM and IPDM E/R


any suggestions?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #2
ok,,... the guys at nissan confirmed that the issue is in the BCM. So, is there anywhere I can buy a BCM for my tiida 2008?

Thanks all.
 
1 - 2 of 2 Posts
Top