Nissan Versa Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey

I changed my ball joint on passenger side, and hub assembly on driver side on last Saturday.

Somehow, I cannot put the red circle part because there is ABS sensor on it.
(I think it is ABS)

so I have let it loose a bit between CV and Hub

after that I found I have ABS sensor on it,

but I don't think that is magnet circle plate, so kinda wondering.

Are there different hub assembly between ABS and non ABS?

and if I let it loose between CV and hub would that be a problem?
 

Attachments

·
Registered
Joined
·
690 Posts
That dust protection plate is the only thing that separates ABS from non-ABS hubs. Very likely the parts guys gave you a non-ABS hub because the differences are indiscernible at a glance. That plate likely snapped off your sensor. So take the hub out, try to remove that plate, or return it and ask for the proper one, and get a new speed sensor.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 · (Edited)
seriously?! oh man.........

Thank you so much


Since my smart dad throw out old part, receipt and basically every things that I can fix this problem,

I might need to buy new plate or run with out one.

Is it still okay to run without the plate? or will it cause problem soon since there is NOTHING to keep out the dust.

and if I decide to run with out one, should I still replace the speed sensor just in case or let it be since is already damaged and will be damaged without one
 

·
Registered
Joined
·
690 Posts
It will be fine since the ABS hub doesn't have that plate at all, figure out some way to remove it i guess, and check to see if the speed sensor is broken. For clarity, the ABS hubs do not have that plate, and non-ABS ones do.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top