Nissan Versa Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello, new(ish) here - bought my daughter a 2007 a few months ago. Got some great help on a speedo issue a few weeks ago, thanks again, guys.

Hope it's OK posting this here, I saw there's an I.C.E section but if this is like other auto forums, everyone probably just hangs out in the general area.

We installed a new carplay stereo today and I was surprised by how many wires were going into the old deck. (3 bundles + antenna) I assume some of them are steering wheel controls + the mic by the map lights but I'm a little confused on the tweeters in the A-pillars and the sub.

Once I saw all those, I figured we were going to loose the pillar tweeters and the sub but we hooked the old head unit back up and realized the sub and tweeters weren't even working with the stock head unit.

so nothing lost from installing the new stereo but are those tweeters and sub supposed to be working? The tweeters are wired up but I don't know where they go. We ran a continuity test between the tweeters and the cable bundles but didn't come up with anything.

I didn't crack the rear plastic covers open to see if there's actually a sub behind the circular grille that is obviously for a sub.

Is this one of those situations where every car off the factory line gets the same speakers but only models with premium sound head units use them?

thanks,
Dan
 

·
Registered
Joined
·
530 Posts
As long as you have retained the factory wiring, the tweeters should be working, unless they are blown.
There are 2 places where the tweeters connect to the harness. One is under the little triangle window (pull down A pillar cover and pull out vent)
The other is under the top of the dash near the middle..
On the main 20 pin radio plug, they will be on the main front L/R speakers (pins 2-3 and 11-12)
Steering wheel controls are on the main plug, pins 6, 15, 16.
 
1 - 2 of 2 Posts
Top