Nissan Versa Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have everything disconnected, but for the life of me, I cannot get the sensor removed. I can rotate it, but it will not come out. I have struggled with this for 2 days. Does anyone have the secret to getting this out?
 

·
Registered
Joined
·
167 Posts
Should be just one bolt to remove, the wire harness of course then the sensor is sealed in the hole by an O-ring, correct? A twisting and pulling action should pop it out. I hear you though. I've had those O-rings really fuse in place due to no lube on it and corrosion. Be it aluminum or iron.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yeah, bolt is out, like I said I can rotate it, but no amount of rocking and pulling gets this sensor out!
 

·
Registered
Joined
·
167 Posts
Sounds like it's just rotating within the O-ring groove on the plastic sensor body and the outer surface of the O-ring is fused to the block. The sensor may break in the process, but it will come out. Can you get a pick or flat blade under the bolt flange on it for leverage?
 

·
Registered
Joined
·
266 Posts
Sounds like it's just rotating within the O-ring groove on the plastic sensor body and the outer surface of the O-ring is fused to the block.
Maybe to spray it with a penetrating oil (like PB Blaster) and let it stay overnight, for oil to work its way between the O-ring and the block.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Thanks guys for the responses. Perseverance, a small flat blade screwdriver, a mirror, and I was finally able to get the thing out. Phew, 7 hours. :(
 
1 - 6 of 6 Posts
Top