Nissan Versa Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi All,

Just purchased a used 2011 Versa S and tried to turn on the cruise control when on the highway but it is not engaging. The CC light on the dash comes on and I push the switch on the steering wheel to engage, but nothing.

Could this be a fuse/relay issue or am I doing it incorrectly?

Any info is appreciated.

Tks
 

·
Registered
Joined
·
690 Posts
Pretty new so unless there's any codes it shouldn't be a mechanical problem. What's the history on the car? Water could have gotten in the switch making it finicky, or it could be the wiring. Check all your fuses as a prerequisite but I don't think cruise control itself has it's own dedicated fuse, it's probably powered by one large fuse that powers a few body electrical systems in general, so if it were a blown fuse you'd probably notice multiple body electrical stuff not working. Try disconnecting battery for a few minutes then reconnecting. You could also swap the steering wheel for a known good one, or take the airbag out and get in the steering wheel electrics and start probing the switch wires to see if the switch works properly.

Well after looking at the cruise control wiring diagram the fuses that power the system are in the dash, that little access panel on the left of the steering column. The fuses that power the cruise circuit are number 7, 2, 3, and 13. Go check it out.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top