Nissan Versa Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi guys, Like a good newbie i've been searching the forums for answers over the last weeks and have read .. well about all the threads I could find on this subject.

Basically I have a 2009 Sedan S with no options, it has a few dings and dents so I have also purchased a 2007 SL sedan. I'm going Tuesday to pull all I can from the '07 before leaving it with the salvager.

I plan on swapping many items including all 4 full doors with the power windows and locks onto my S. My curiousity is if I swap the bcm and keyless transponder from the SL, will my ECU kick out an error realizing they have been swapped? My main desire is to swap it all, rewire what i have to from the doors, and not have to go to the dealer for a reprogram of the BCM.

I've done many breakdowns and builds in my past but this is my first with such a newer vehicle and the BCM. I'd appreciate any input. Thanks!!


And of course I have my own large list of parts i'm pulling, but feel free to toss in ideas as well.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Josh, thanks for the ideas I actually had not considered the A-pillars the rest is on my list. Both vehicles are white... just ended up the parts car was cheaper than the body shop quotes, lol.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
no arguement very lucky. I only have a day to grab all I want though so this morning will be a fun rush of dismantling. Was hoping others may have more input on my questions though... anyone?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
So to close this idea, I have swapped the four doors from the SL model.

It took me too long to realize that regardless of the BCM issues the wiring is not even in the dash harness to the BCM or Doors for Power windows. As they work on a 12v system I have wired the windows in directly with an inline fuse off of the battery. I started with driver side then passenger and both rears do have the full wiring up to the front foot well so you can catch the pigtails in the harness connection there instead of tracing it all the way back.

Took quite some time to be sure I had it all correct but everything works perfectly from the main switch (drivers) and each individual switch. Auto up, auto down/ and anti-pinch system all work correctly as well.

I have ended my project there and will not continue on with attempting to make the OEM power locks work.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top