Nissan Versa Forums banner

21 - 40 of 151 Posts

·
Registered
Joined
·
7 Posts
dear all,
i recently bough a Nissan Tiida Latio; Imported from Japan. MR18DE Engine with CVT gearbox. kept driving for almost a week as was trying to finish the paper work here in Namibia. There was a small dent on the fender due to off loading. i fixed it at a local panel beater and collected the car. i observed that some areas need to be polished so the panel beater shop said i must leave next morning and get during lunch. when i went to collect the car during luch, the guy drove the car out for me and gave me the key. i stated and put the car in reverse. suddenly the car died and wont start lthough will crank. i left the car there. they disconnected the terminals and reconnected when i went after work. it started, i drove almost 5 KMs and was close to my place when the car died again and never started. i towed the car to a mechanic who is good in japanese imports. he said, it was starter motor, replaced, no change. he replaced crank shaft sensor, no change. now he ays it is computer box. i am very worried, can some body help?
 

·
Registered
Joined
·
223 Posts
I have oil seeping into the middle spark plugs. one is very minute but the other had at least 2 ozs of oil it when i did the plugs. cause. nissans m ade a 2 peice head and used a liquid gasket in between em and mine has rotted away
 

·
Registered
Joined
·
208 Posts
I haven't had any issues (she's still new 3k+ on her). But I am curious...
Those of you who are having issues, did you do any mods under the hood?
Maybe with this thread we could list the mods that were done along with the list Frenchy chan stated.
 

·
Registered
Joined
·
238 Posts
2009 Versa S MR18

Late 2011, I kept getting the check engine light with P1421 - Cold start ignition control.
No one could give me a clear answer as to what exactly this was as my car still acted perfectly normal. Took it to Nissan and they kept it for a day and gave me a Sentra to drive in the meantime while they fixed it. It was covered by my warranty though and the tech said it was "basically a sensor problem"

/shrug
 

·
Registered
Joined
·
2 Posts
2011 Versa engine block replacement

With 35,000 miles on a 2011 Versa S 1.8 the engine has been making a noise that I thought was a valve problem. The dealer informed me that it needed a new engine block assembly. Does thiis make sense to anyone? Should they extend the warranty after replacing the block?
 

·
Registered
Joined
·
124 Posts
a couple of times in the past days, i started the engine and the "O/D OFF" light didn't go off.
i turn off the engine and start again, and it's gone.
i still don't know why this happens!
You might accidentally push the button with your thumb when you park up for the night. A lot of my friends do it because as their getting out they grasp the entire knob in preparation of leaving. Anyways its the tiny black button on the left side of your shifter if your in America/Canada. Might be opposite in the U.K. and Europe. Ideally you should leave O/D on even when you don't feel you need it as it improves fuel economy on hard accelerations and stop-gos.
 

·
Registered
Joined
·
124 Posts
With 35,000 miles on a 2011 Versa S 1.8 the engine has been making a noise that I thought was a valve problem. The dealer informed me that it needed a new engine block assembly. Does thiis make sense to anyone? Should they extend the warranty after replacing the block?
Seems like their just replacing a piece of plastic or the metal frame. If its even slightly off what your referring to basically is your engine is not sitting properly that is it is favoring one side or corner more then it should be. Let them replace it as it is a unique issue. Perhaps a lot of 2011 will be recalled? Sadly warranty extensions are bad for business as the purpose of most dealership warranties or factory warranties are to protect your vehicle up until about the time the parts start to fail. I take the steps of fluid changing/flushing/rust removal/ and part replacement just to be sure I'll have a versa after I hit 100k miles and 10 years.
 
Joined
·
124 Posts
I have oil seeping into the middle spark plugs. one is very minute but the other had at least 2 ozs of oil it when i did the plugs. cause. nissans m ade a 2 peice head and used a liquid gasket in between em and mine has rotted away
So you just had to replace the rubber gasket and spark pluh? Be careful your engine block might have a crack. Either way engine oil on spark plugs mean when you start it up thered will be black smoke and knocks/pings/backfires.
 

·
Registered
Joined
·
124 Posts
I haven't had any issues (she's still new 3k+ on her). But I am curious...
Those of you who are having issues, did you do any mods under the hood?
Maybe with this thread we could list the mods that were done along with the list Frenchy chan stated.
I think there are several modification threads out there already but it is absolutely relevant for people who have experienced a engine failure to list any mods that may be a factor. UI just don't want to see "My 40" 's and Spoiler made it go so fast the block exploded," LMAO.
 

·
Registered
Joined
·
124 Posts
dear all,
i recently bough a Nissan Tiida Latio; Imported from Japan. MR18DE Engine with CVT gearbox. kept driving for almost a week as was trying to finish the paper work here in Namibia. There was a small dent on the fender due to off loading. i fixed it at a local panel beater and collected the car. i observed that some areas need to be polished so the panel beater shop said i must leave next morning and get during lunch. when i went to collect the car during luch, the guy drove the car out for me and gave me the key. i stated and put the car in reverse. suddenly the car died and wont start lthough will crank. i left the car there. they disconnected the terminals and reconnected when i went after work. it started, i drove almost 5 KMs and was close to my place when the car died again and never started. i towed the car to a mechanic who is good in japanese imports. he said, it was starter motor, replaced, no change. he replaced crank shaft sensor, no change. now he ays it is computer box. i am very worried, can some body help?
That crank noise is good my friend. it means your starter is functioning and starting as it should. Whats kinda cool to think about but not cool to have it happen to you is that while your car runs it should be rechaqrging the juice used for starting, lights, radio, what ever. It sounds like the part of the car that does this recharging (which I believe is called the alternator) may not be functioning as it should. That would explain your starts and then slowly no starts at all.
 

·
Registered
Joined
·
124 Posts
I haven't had any engine trouble but I do have a whistling noise when I'm coming to a stop. Seems to be coming from the wheels, sorry can't remember if the front or rear once. It is hell of annoying though lol.
How loud is the whistling noise? It could be 3 things.

1. Your tires are locking up/brakling too hard where they skid to a stop. The skidding is the whistling noise.

2. Your brake pads are worn out and screech whenever they are used (most likely the front as they have a screeching mechanism which basically is a large metal inner ring that grinds whats left of the metal pad/shoe.

3. Your brake shoes/pads have accrued a lot of brake dust to the point where minor squeeks occur when you brake in reverse or drive.
 

·
Registered
Joined
·
124 Posts
2009 SL Hatch with CVT. MR18DE. Cylinder 3 failure started at 65,000 miles.

Started as light tapping in the cold in winter of 2010. Would be ok when warm. By mid 2011 it was tapping no matter the temp and even once warm. Started experiencing massive oil burning. Oil light came on twice in a month before I realized something was very wrong. By winter of 2011 had a very obvious lump at idle. Engine would die unless I came to very light stop. Replaced engine @ 84,000 miles new years weekend 2012 with MR20DE. After 600 miles new engine running great, no check engine light.

Original info here

Video of engine once it started going bad.

MR18 Running like crap, dieing, ticking - YouTube

**** PLEASE LIST THE FAILED CYLINDER IF KNOWN *******
Sounds like your block was cracked on a cylinder containing one of the spark plugs. The only way we would have known is if you took the plastic gaurd off and showed us the cylinders. Then again you would have been able to tell as it would have oil all over it lol.

Next time bring it in sooner as the longer you wait the more compromised the engine becomes.
 

·
Registered
Joined
·
2 Posts
2007 Versa...Engine knock and smoke

Hi Have a 2007 Nissan Versa with 128,000 kms. Engine has a very loud hammering noise(cold or hot) and thick oily smelling smoke on start-up. Thinking she is done. Any suggestions....Thanks
 

·
Registered
Joined
·
1,616 Posts
We've seen engines blow at lower mileage. If it truly is done for, I'd look into the MR20 swap. If you're able to do the work yourself, the engines are fairly inexpensive.
 

·
Registered
Joined
·
643 Posts
Discussion Starter #35
My engine has started making a humming noise around 2500 rpms :(
I forget my mileage at the moment, though...
 

·
Registered
Joined
·
1,965 Posts
Mine has started to tick more now that its gettng colder out I'm hoping it lasts at least a bit longer for me then when it goes I'm goin to the mr20
 

·
Registered
Joined
·
1,616 Posts
Mine has started to tick more now that its gettng colder out I'm hoping it lasts at least a bit longer for me then when it goes I'm goin to the mr20
Personally, I wanna find a wrecked sentra spec v and do the qr25 swap. I've been looking into it lately.
 

·
Registered
Joined
·
2 Posts
Hello All- New here- only joined to say...

I have a 2007 Versa. 58000 miles and Nissan is saying the engine is full of sludge and needs to be replaced. I did some looking online and found many similar stories, some with only 20 or 30 thousand miles on them. I also found this.

Nissan Versa – Class Action Investigation - Chimicles & Tikellis LLP

There may be a class action lawsuit regarding the 2007 Versa due to a really high incidence of engine failure and Nissan's refusal to recall or pay for repairs even under warranty. I just wanted to share so if anyone has had this issue they can maybe get some help.
 

·
Registered
Joined
·
122 Posts
Yes, you will have a 12,000 mile/12 month warranty after this is completed. This is a standard prcatice that manufacturers HAVE to offer. This is to protect you after a major service. Even on smaller jobs, when installed by the dealership, you will recieve a 12/12 warranty....on the installed part and installation...NOT an extention of your factory warranty. Hope this helps.
With 35,000 miles on a 2011 Versa S 1.8 the engine has been making a noise that I thought was a valve problem. The dealer informed me that it needed a new engine block assembly. Does thiis make sense to anyone? Should they extend the warranty after replacing the block?
 
21 - 40 of 151 Posts
Top