Nissan Versa Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello,

I have a 08 Nissan Versa and since the middle of September I have been having issues with the heater core. It has been into the dealership twice, and as of today three times to have the heater core replaced. It is a fairly long story but I'll try to condense it down.

Towards the beginning of September I had to make a trip to pick up some of my belongings as I was moving. About 900 kilometers into my trip I noticed the steam and smell of something leaking. After pulling over I noticed the puddle of fluid on the floor of the passenger side of my car.

I called a tow truck and had my car towed into Jasper, AB where a small mechanic shop put a bypass on the heater core. Upon returning home I brought my car to the dealership where they booked it in to have it replaced.

The new heater core worked for approximately two weeks and I was having the same issues again, fogged up windows, steam coming out of the vents, etc. Brought it back to the dealership again, sure enough heater core was leaking. They replaced it within a week and said that the last part must have been faulty.

The second heater core worked for about a month, and just this morning driving to school same thing again. The steam fogged the windows to the point where I could no longer drive, even with all of the windows rolled down.

I've brought my car back to the dealership again, but I fear that they are just going to put in another heater core and the same thing will happen again in a month or so. I'm not great with cars, but I figure there must be something puncturing the line or an alternate problem.

I get my car checked regularly and had it in for an oil change before I made my long haul trip to Jasper. It has a few kilometers on it (117,000) as I do quite a bit of driving, however I was told that a heater core should last a vehicle its lifetime.

Has this happened to anyone else? Any ideas of what it could be? I am at a loss for ideas, and it is getting to be an inconvenience for me.
 

·
Registered
Joined
·
339 Posts
Sounds like a problem else were. Have you had a radiator pressure check done? Sounds like a possible overheating problem. I would check to make sure the water pump is good as well as the thermostat. Did they ever say were the heater core was leaking from? This could point you in some direction.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top