Nissan Versa Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Two weeks ago my car just wouldn't start. I have an 2007 nissan versa SL hatachback. The car just randomly wouldn't start, never had a check engine light on or anything. Replaced the fuel pump and the car started but was shaking when I applied gas. The check engine light came on. Read crankshaft sensor, random misfire and cylinder 4 misfire. I changed the spark plugs and the crankshaft sensor but the car still won't start. After I changed the spark plugs it read cylinder 1 and random. My only other thought would be the coils. Some mechanics are telling me I would have to replace my computer and all that.
 

·
Premium Member
Joined
·
148 Posts
Be sure to double check your vacuum lines as well.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I'm going to have it towed on Friday to a shop. That way I can have them take time and find the problem. I'm tired of putting money into it and it not fix the problem.
 

·
Registered
Joined
·
440 Posts
Could be dirty injectors, clogged fuel filter, or even a clogged catalytic converter.

Did you replace the spark plug wires when you did the plugs? It could be grounding out. Sometimes if you start the car in the middle of night with no light you can actually see arching.
 

·
Registered
Joined
·
75 Posts
Theres no spark plug wires to replacd, these engines have coilover plug set-up. I would check compression, and have the intake smoke tested for any leaks. A large vaccume leak can cause a major running problem. Etc. Missfires
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
They tested coil one and it is not getting any spark. We changed the camshaft sensor and he is thinking a computer problem. I was told I don't have a single computer and that it is divided between my coils.
 
1 - 7 of 7 Posts
Top