Nissan Versa Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
*I'm a french Canadian, please bear with me for my english

Hi everyone,
Long story short, i'm a new owner (as of today) of a 2007 Nissan Versa Sedan (non CVT) Automatic. 242XXX Km on it.
My friend sold me the car for 250$ because he had problem with it and didn't want to waste more money on it (2000$+ invested in the last 2 years). Yes his lost will be my gain :grin . But first I have to fix those issues.
I'm an apprentice mechanic and I would like to know what you guys think of this problem:

- About 3months+ ago, the "Evaporative Emission Control System Vent Control" stopped working and it takes forever to fill up the gas tank. Obviously the valve in the gas tank to regulate the pressure is not working. I will make a few check up by looking at the spec for the resistance and continuity. If one of the tests fail, I will replace the part. But I don't think it's the issue here. You will see why in a moment.

- Approx 2 weeks ago, my friend went to teach a class at the university. After class, he got back to his car to drive back home. He started it but the engine run for about one second then shut offs. Nothing he could do. He brought it to a mechanic and they said that there's multiple codes (didn't told him which one) and also said that when you erase the codes, the car runs fine without any problem. Like there's nothing wrong with the engine management or anything like that. As soon as you turn it off and try to restart it, codes are back and the car wont start unless you erase the codes.

At that point he was fed up with the car and sold it to me.

Once I got the car at my place I've checked the codes, here's the list:

P0448 NISSAN - Evaporative Emission Control System Vent Control (Circuit might be shorted)
P2103 NISSAN - Throttle Control Motor Relay Circuit Short
P1564 NISSAN - ASCD Steering Switch
P0720 NISSAN - Vehicle Speed Sensor

I tried to start the car without erasing the codes and miraculously, it runned and stayed on. When I press the gas, nothing happen, no acceleration. I've put in drive, it goes foward, but still no "power" stays at 600-700rpm, a little lower than normal running condition. I've open the gas cap to see if anything change. A ''pshhh' sound came out, means there was negative pressure in the gas tank. Nothing changed, still running sloppy.

Exept the Evaporative Emission Control System Vent Control, all the other codes point out to the ECM. I want to try another ECM, but apparently, I have to reprogram it at a nissan dealer for 120$CAN.

Before doing this, I would like to know what you guys think.
I will try this also just to make sure grounds are good: https://www.autocodes.com/pdfview.php?pdflink=https://www.autocodes.com/uploads/nissan/NTB06-009a.pdf

Notes:
1-My friend changed the battery 2 months ago.
2- Ice and snow is melting at that time of the year, could it be water in the ECM?

Thank you in advance.
Cheers my New versa community :nerd:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Update


Hi, thank you for your help.
I tried everything step by step. It didn't work.
The weird thing is that, right after doing so, I erased all the codes to have the car run fine, but the car was not shifting gear. I read the codes before turning off the engine, and no codes... but not shifting :confused5:
I turned off the car, erased the codes again and the car worked fine.
It's like when it does the first check up cycle before start, it fails at some point. It engage a "safety mode" and turn off the engine to make sure no damage is done to the engine.
Looks like a communication error. I will clean all the ECM / TCM grounds and make sure it makes a good contact with the body. I'll look for rusted connectors too.
Somebody told me to try to start the car with the MAF unplugged, but i'm sure it's not that.
Thanks for the help, I will keep you posted on that.
 
1 - 3 of 3 Posts
Top