Nissan Versa Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #1 ·
Hello,
2007 Nissan Versa SL six speeds. I need to replace the torque strut mount and need some information. I was inspecting the part and it looks like I will only need an 18mm socket and ratchet for the two bolts that pin the part to the passenger side strut pillar and the side of the engine.




Do I need torque specs for install and do I need to apply thread locker to these bolts? As always, any help answering these questions will be greatly appreciated.
Happy Thanksgiving!
Miguel
 

·
Registered
Joined
·
377 Posts
Hello,
2007 Nissan Versa SL six speeds. I need to replace the torque strut mount and need some information. I was inspecting the part and it looks like I will only need an 18mm socket and ratchet for the two bolts that pin the part to the passenger side strut pillar and the side of the engine.




Do I need torque specs for install and do I need to apply thread locker to these bolts? As always, any help answering these questions will be greatly appreciated.
Happy Thanksgiving!
Miguel
How did you determine that you needed to replace it? I have had some weird vibrations so I had a friend rev the engine while I looked at it, and it didn't move around at all or vibrate too much, and the mounts looked fine. Is this the procedure you followed? What happened?
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #3 ·
How did you determine that you needed to replace it? I have had some weird vibrations so I had a friend rev the engine while I looked at it, and it didn't move around at all or vibrate too much, and the mounts looked fine. Is this the procedure you followed? What happened?
I simply looked at the part and the rubber is all torn up... like missing chunks of it. I figure, if I don't replace this part it might lead to damage to the other mounts.
 

·
Registered
Joined
·
102 Posts
Yep.... easy swap. just get them good and tight.

I have been thinking of urethane filling mine. got 23K miles and I can start to feel it starting to go. (visually I see a few cracks)
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #5 ·
I got my inspection sticker (required in Texas) in August and the tech at the shop told me that I needed this work done to the car, but I didn't see the cracks that he was talking about. I just thougth they were trying to squeeze some more money out of me. The tech quoted me parts and labor for $221.50. I am confident that with all of your help I will be able to replace this part by myself.
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #7 ·
I replaced this part in about 5 minutes. U do not need to support the engine as it is not an engine mount. 2 bolts take em out, take part off put new part on replace bolts. its that easy.
Great, I hope the replacement of this part goes as fast as yours. The part has been ordered and its on its way to me. :thumb2:
 

·
Registered
Joined
·
377 Posts
Just shot a bit of video of my engine moving around as I hit redline in neutral. This would indicate I need to replace these right? I think I can have the dealer do it (warranty). Any thoughts?
 

·
Registered
Joined
·
377 Posts
Does that moving engine video help? Scary shit huh?
 

·
Registered
Joined
·
377 Posts
You know, weird thing is that the top mount looks to be in decent shape...maybe the bottom on is messed up. Not as much rubber as that picture but nothing cracked or fractured.
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #14 ·
Happy new year! I got my torque strut replacement and the install was pretty easy. I will post a how to on this soon.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top