Nissan Versa Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hopefully someone here can help my moms got a 07versa 180k on it she's goes out the other day starts it an it sounds like a built STI outside any idea what it could be she ran it dry of oil a few weeks ago but did a change filled it up an has been running fine up till the other day I can turn a wrench just I don't dig to deep into motors just make cars look good while going fast that's it lol any help or ideas of what might be the problem are appreciated
 

·
Registered
Joined
·
674 Posts
Can you give us a little better description of the noise your hearing??? If she ran low on oil, there could have been some engine damage that is just showing up now.
 

·
Premium Member
Joined
·
3,272 Posts
that happened to me too. What it was for me was my muffler flange rotted out and the muffler came totally disconnected from the rest of the exhaust.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Already replaced the exhaust about 3 months ago an its running like it has a dropped cylinder I spoke to a buddy of mine that works at a Nissan dealer an he said he's had a few come in with the same issue an they just replaced the motor something to do with the cylinder heads an as from coming from the motor its all I can think it is comingfrom extremely bad shaking can here multiple taps witch made me think the valves may have gotten damaged I originally thought it may have jumped timing because my buddys timing belt stepped at one point an when we got it replaced found out the valves were messed up id rather replace the motor then having to strip it down an rebuild it just trying to at least have a good idea of what it is before either trying to repair it or replace it
 

·
Registered
Joined
·
674 Posts
Already replaced the exhaust about 3 months ago an its running like it has a dropped cylinder I spoke to a buddy of mine that works at a Nissan dealer an he said he's had a few come in with the same issue an they just replaced the motor something to do with the cylinder heads an as from coming from the motor its all I can think it is comingfrom extremely bad shaking can here multiple taps witch made me think the valves may have gotten damaged I originally thought it may have jumped timing because my buddys timing belt stepped at one point an when we got it replaced found out the valves were messed up id rather replace the motor then having to strip it down an rebuild it just trying to at least have a good idea of what it is before either trying to repair it or replace it
The issue that some of the Versa engines have is what they call a "piston slap". Some engines that have this condition will run 100,000 miles with this issue, and other engines like mine were ready to crap out at just over 30,000 miles. What happens with a "piston slap" is that the piston rocks back and forth as it moves up and down in the cylinder causing a noise. Eventually the noise gets louder, and in some engines, the rings start to fail, the engine burns more oil than usual, and in some instances the piston rings will eventually fail and the engine will run like crap. If your engine had this condition and had run low on oil, it is possible that this accelerated the piston rings failing and is causing the condition you noticed. My 2009 was still under warranty when the dealer agreed to put a short block in. If you go that route you are looking at about $3000 in repair bills. If you can get your friend to do a compression test, it might give you a better idea about what your facing. Good luck!!!
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
4 Participants
pimperell
Nissan Versa Forums
We’re a forum community dedicated to Nissan Versa owners & enthusiasts. Come join the discussion on performance, troubleshooting, accessories, purchasing, maintenance and more!
Full Forum Listing
Top