Nissan Versa Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey Guys... new guy here. I have been driving my moms versa a lot lately. She is not well, and I have been playing taxi dude.. The car has 71000 on it. It has been super reliable. no issues really. Its a 2009. She is going to give me the car eventually, so I am basically taking care of it now. So I need to start learning more about it . so here I am.. Today the check engine light came on.... I went by the dealer.....oops bad idea... I went by Advanced auto. they hooked up their little code reader and it said p0507. ...Idle air control system rpm higher than expected.... Mom hit big dip other day full speed.. maybe air box got knocked loose?? not sure. some thing in the air intake system?? the idle seems to fluctuate between 800 and 1100 sometimes...I guess the guy reset the code because light went off on the dash. What do you guys think?? I am going to see if I can find anything loose under the hood tomorrow. still runs fine.. Thanks J G F
 

·
Premium Member
Joined
·
790 Posts
Hey Guys... new guy here. I have been driving my moms versa a lot lately. She is not well, and I have been playing taxi dude.. The car has 71000 on it. It has been super reliable. no issues really. Its a 2009. She is going to give me the car eventually, so I am basically taking care of it now. So I need to start learning more about it . so here I am.. Today the check engine light came on.... I went by the dealer.....oops bad idea... I went by Advanced auto. they hooked up their little code reader and it said p0507. ...Idle air control system rpm higher than expected.... Mom hit big dip other day full speed.. maybe air box got knocked loose?? not sure. some thing in the air intake system?? the idle seems to fluctuate between 800 and 1100 sometimes...I guess the guy reset the code because light went off on the dash. What do you guys think?? I am going to see if I can find anything loose under the hood tomorrow. still runs fine.. Thanks J G F
Hi, welcome!
I actually had this same code pop up for me a few months ago. I would just like you said, inspect the air intake parts, and make sure your filter is clean. I cleaned up my filter (K&N drop in filter) and vacuumed around the filter area and have not had the code come back up again. I can't really say I fixed the problem, but for the time being the light has not come back on. Knock on wood!
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
2 Participants
sergmx
Nissan Versa Forums
We’re a forum community dedicated to Nissan Versa owners & enthusiasts. Come join the discussion on performance, troubleshooting, accessories, purchasing, maintenance and more!
Full Forum Listing
Top