Nissan Versa Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I’ve been having an issue with my 2013 Nissan Versa sv CVT for about 2 months. While driving on the highway the engine RPMs will be abnormally high. Sometimes I notice the RPMs seem to go from 4K to 3500 back and forth. I’ve also noticed while accelerating the transmission seems to be “searching” for the right point. The car will jerk when accelerating and feels like it’s shifting from 1,3,2,4,2,3. (Random ups and downs). While at a stop with the car in drive the engine idles very rough, shaking the car. Sometimes with the a/c on the idle is better.
 

·
Registered
Joined
·
379 Posts
It sounds like you've got issues with the CVT. If that's the case unless you undertake trying to rebuild it yourself you're probably looking at a new/rebuilt transmission at the cost of a few thousand dollars. Only thing you might try is a fluid filter change but there's no guarantee that would do any good at this point.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
yeah, I tried a drain and refill. Unfortunately, I didn’t notice any difference. I was hoping there could be an external sensor causing this issue.
 

·
Registered
Joined
·
286 Posts
If you're having issues at idle, at a stand-still, this may not be CVT related at all.

Have you scanned for codes or ever had a check engine light?

Have you had a dead battery or a battery change any any engine work done recently? You may need to do a throttle re-learn. There's threads and youtube videos on how to DIY.
 
1 - 4 of 4 Posts
Top