Nissan Versa Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
After buying my 2014 Nissan Versa S+ I realized that the sound system wasn't exactly the best thing out there.

I wanted the ability to make hands free calls and stream my music from my iPhone by either Bluetooth or plugging it in via a USB Port, HD radio and the ability to add XM Satellite radio. (I'll add that at a later date.)

I also wanted something that I could easily plug an amp into. I've already ordered my subs and amp and I'll do a separate write up on that install at a later date.

Whether it's by laziness or bad luck with the search button, I've had trouble finding all the information in one place for what parts I would need for an easy install on the 2nd gen Versa using a double DIN radio. Luckily I have now created that list and included some pictures of my questionable handiwork.


Parts Needed:

Metra 70-7552 Wiring Harness (This is rather straight forward wiring wise. Match up the appropriate wires and solder them together. You can also connect them in other ways but soldering is the best IMO. Mount the Black wire from the headunit to a ground, not to the wiring harness. Otherwise you'll be very annoyed/confused when your headunit doesn't work like I was for a few minutes.)

Metra 40-NI12 Antenna Adapter (Connect the blue wire on this adapter to the power antenna cable wire on the wiring harness.)

Stock Head Unit Mounts (You'll re-mount the new Double DIN unit using these two pieces.)

Phillips Head screwdriver

Torx T20 screwdriver/bit (For one of the screws on the doors if you're removing the trim to install speakers.)

I also thought I would need a mic for the Bluetooth hands free calling but (probably since I didn't read far enough into it) the head unit I bought came with a mic. I routed the wire from the back of the head unit under the dash up through the fuse box and A-Pillar to where it came out right over the rear view mirror. Sorry, I don't have photos of this. :(

It also came with a male to female USB cord which was just long enough for me to route it into the glove box (My versa doesn't have a center console.) where I could hide it along with my phone.


Head Unit used in this installation:
Pioneer® AVH-X5500BHS


Speakers used in this installation:
SONY XS-R1644 6-1/2" 4-WAY COAXIAL CAR SPEAKERS
I saw there is already a guide (See Versa12's Sticky on Speaker installation. It helped me out a bunch.) that goes into depth for speaker installation so I won't be covering much of that. I did however use Boom Mat 6-1/2" slim line speaker baffles to help with keeping the speakers sealed and improve sound. Do they really help? Who knows. Some people say they negatively effect bass response but I'm adding subs anyway. I didn't use any speaker adapters and mounted them directly in by drilling holes. You could hear the window rub just a little bit on the baffles but other than that the install went perfect.



Dash pulled apart with Head Unit removed.



Left and Right view of the stock mounts on the aftermarket head unit. If you're lazy like me you can mount the ground the same way I did in the photo above. My car hasn't caught on fire yet so it has to be safe right?




Left and right view of the head unit sitting in the dash.



Head unit powered up and working.



Completed look with the dash back together.



Nothing to see here...


It's worth noting that there is a little gap around the edges which you can see around the head unit once it's put back together. I was looking for something to help make this a little less noticeable and a bit more complete. I still haven't found something that works with this particular head unit, but do not buy the Scosche DDTRB Universal Double DIN Trim Ring with this unit. It doesn't work.

I hope this guide helps a few people out there avoid a couple of headaches!
 

·
Registered
Joined
·
3 Posts
Hey you guys I don't know if you all even check out this thread anymore.. I just made a account just so I can ask a question on this thread.. I've had this thread bookmarked for awhile because I'm going to replace the stereo in my car.. I have a 2014 Nissan versa sv.. It has the same setup as the op.

I just got the last wire I need to start setting everything up but I notice that on the wire I have there's 2 ground wires coming from the head unit harness and there's 1 coming from the harness that plugs into my cars harness.. I notice you said don't plug them together but ground then to like a screw on the stereo like you did.... So am I suppose to ground all three wires to a screw on the head unit or anywhere on the car chassis?

I know this thread is old so if I don't get a response it's cool.. Btw I have a pyle pldnv77u
 

·
Registered
Joined
·
3 Posts
Oh and after reading up some more what I'm starting to get is that the ground wire on the harness isnt actually grounding anything because Nissan doesn't ground through the wire hardness but through the atenna or when the stereo is bolted to the car.. So what I'm getting is that the ground wire off the harness I don't have to do anything with that but the two ground wires coming from the head unit I should ground those to idk a stereo bolt or somewhere along the chassis
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
The harness one I wouldn't worry about. Try grounding the two from the head unit to anything on the car frame. I think I grounded it back to one of the head unit screws.

That may be bad advice however. But the ground on the adapter harness shouldn't matter. Only wires hooked up to the actual unit as the ground in the harness doesn't do anything.
 

·
Registered
Joined
·
3 Posts
I actually got it in there and only grounded one wire and it ended up draining my battery.. So I took it out and just hooked up the ground wires together and its working.. It still killed my battery idk why...... As I'm typing this my car battery is charging..


I went back took it out and redid everything.. This time I had a friend who knows about putting stereos in cars and he said put the ground together with the one from the harness hooked it back together and everything worked fine.. Now I just need to figure out why my battery is draining

If you have any ideas on why it would kill my battery I would greatly appreciate it. I know it could possibly just be the battery
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
I'll be honest. I have no clue. I'd say that it might be a short somewhere but that's just a really bad guess. You might want to return the unit and try again just to see if it's that.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
I'd recommend making this a sticky due to a couple of people asking about it on this forum. However that's up to the admins.
 
1 - 9 of 9 Posts
About this Discussion
8 Replies
4 Participants
psygnosi
Nissan Versa Forums
We’re a forum community dedicated to Nissan Versa owners & enthusiasts. Come join the discussion on performance, troubleshooting, accessories, purchasing, maintenance and more!
Full Forum Listing
Top