Nissan Versa Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
alright here it goes. About 2 weeks ago my wife was driving her car and her overheat light came on. turns out it was a hole in the radiator so I took that one out, spilled about a quart of ATF in the process. Well I ordered a new radiator and got it yesterday. So this morning I put the new one in and got everything hooked up and filled the radiator and overflow with the Nissan blue coolant. I haven't put any fluid in the tranny yet because it still says its full which is hard to believe after spilling some. so that's one of my questions. The other one that is really puzzling me is I started it up to check for leaks or anything weird and the ABS, Slip and Low Tire warning lights are on? What does this mean? Thank you for reading.
 

·
Registered
Joined
·
691 Posts
Disconnect the battery, touch the negative and positive cables together if they reach, then reconnect.
 

·
Registered
Joined
·
691 Posts
Well it's either pure coincidence or you pinched/broke/unplugged something in the process of taking the rad out or putting the new one in. If you have a CAN line communication code or multiple codes then you probably broke a wire or routed it too close to some interference like a fan motor.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Well it's either pure coincidence or you pinched/broke/unplugged something in the process of taking the rad out or putting the new one in. If you have a CAN line communication code or multiple codes then you probably broke a wire or routed it too close to some interference like a fan motor.
Well now I feel like a stupid idiot. The second the wheels hit the road the lights went off! I drove it about 10 miles and everything seems to be working perfect! Thank you all for all the help!
 
1 - 9 of 9 Posts
Top