Nissan Versa Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All,

My name is Aubrey and I have a cute 2012 Nissan Versa that is Dark Blue. As we speak it is having its engine replaced. :crying: I pulled an error last November on cylinder 3 with 74+K miles. At the time I thought it was just the spark plugs... turns out that the engine was lacking compression. So at this point I new I needed an new engine, but I couldn't afford it yet- fast forward to tax season where I get my tax return... Well I've been looking into shops to replace my engine because a new cost costs more. Found a guy to do it, but then my engine lost power on the freeway last week and I couldn't wait anymore. Turns out what killed me was my crankshaft sensor wire was burned and so when I turned off my car after coasting off the freeway to a parking lost, it wouldn't turn back on.... sooooooo now I wait to get it back. And after having had mileage issues on it for the last couple years do to burning oil at an incredible rate do to a faulty spark plug housing... So, I still love my car, but it has been a pain in the but for a bit... Luckily the blueberry will be back in business this week.
 

·
Registered
Joined
·
686 Posts
Hi All,

My name is Aubrey and I have a cute 2012 Nissan Versa that is Dark Blue. As we speak it is having its engine replaced. :crying: I pulled an error last November on cylinder 3 with 74+K miles. At the time I thought it was just the spark plugs... turns out that the engine was lacking compression. So at this point I new I needed an new engine, but I couldn't afford it yet- fast forward to tax season where I get my tax return... Well I've been looking into shops to replace my engine because a new cost costs more. Found a guy to do it, but then my engine lost power on the freeway last week and I couldn't wait anymore. Turns out what killed me was my crankshaft sensor wire was burned and so when I turned off my car after coasting off the freeway to a parking lost, it wouldn't turn back on.... sooooooo now I wait to get it back. And after having had mileage issues on it for the last couple years do to burning oil at an incredible rate do to a faulty spark plug housing... So, I still love my car, but it has been a pain in the but for a bit... Luckily the blueberry will be back in business this week.
I would venture a guess that the oil usage you describe was caused by a piston slap in the number 3 cylinder that eventually causes an abnormal amount of oil usage along with a loss of compression over time. This is a problem that Nissan has had to address quite a few times. My wife's 2009 versa sedan had the engine replaced under warranty with less than 30,000 miles on the engine because of the number 3 piston issue. Good luck with your replacement engine.
 
1 - 3 of 3 Posts
Top