Nissan Versa Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Greetings, my name is Jamie and I hail from the land called North Carolina. I bought my Nissan Versa Sadan (S model) in 2008 and have enjoyed it (for the most part). The only problems that I have had with the car is with my A/C. So far I have had my condenser, compressor and evaporator replaced. Hoping the third time was the charm. I have a Nissan Cube radio coming in the post and going to see if I can get it working in my Versa (will post pictures and will let you guys know if it works). Anyhow, just wanted to say thanks for the forums - lots of good info here.
 

·
Registered
Joined
·
2,466 Posts
Cube radio should work perfect. Use search to find other installs. Beautiful down there in NC! Welcome:D
 

·
Registered
Joined
·
1,963 Posts
hey welcome to the forums what part of nc you from?
 

·
Registered
Joined
·
1,206 Posts
Im from winston salem NC, and you?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #12 ·
Just a quick update. I got the Cube radio today and installed it without a hitch. Followed the video for removing the radio with one slight difference. I did not actually need to unplug the hazard light as there was enough slack in the cable to place it out of my way. Also the brackets on the cube radio where different than the one on my radio so I used a T20 bit to remove the screws securing the bracket and swapped them out. To be honest I think the cube radio picks up stations better.
 

·
Registered
Joined
·
247 Posts
Greetings, my name is Jamie and I hail from the land called North Carolina. I bought my Nissan Versa Sadan (S model) in 2008 and have enjoyed it (for the most part). The only problems that I have had with the car is with my A/C. So far I have had my condenser, compressor and evaporator replaced. Hoping the third time was the charm. I have a Nissan Cube radio coming in the post and going to see if I can get it working in my Versa (will post pictures and will let you guys know if it works). Anyhow, just wanted to say thanks for the forums - lots of good info here.
wow, you've already needed that replaced in the AC? what is it doing exactly?

The A/C kinda sucks in the Versa, I noticed in ours it sucked at blowing it out, even on high. It sucked driving it on the 100+ days here because it wouldn't really cool down or blow well.

Glad the Cube radio worked! We swapped our stock deck for an aftermarket nav deck. Which we put the stock back in when we sold the V and put the stock back in her.

welcome to the forum!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #14 ·
Well the problem with my A/C is that each season that I go from cold to hot air and then back to cold it loses it's ability to cool. At first the problem was the condenser, then the following year it was the compressor and then the evaporator. I don't see how going from cold to hot could cause that... I'm thinking there is some other problem but we will see if it does it again this year. If so I'm thinking I got a lemon.
 

·
Registered
Joined
·
247 Posts
Well the problem with my A/C is that each season that I go from cold to hot air and then back to cold it loses it's ability to cool. At first the problem was the condenser, then the following year it was the compressor and then the evaporator. I don't see how going from cold to hot could cause that... I'm thinking there is some other problem but we will see if it does it again this year. If so I'm thinking I got a lemon.
Yea, it sounds like you have a lemon. My car is 12 years old and the compressor just died, so nothing on yours should be going bad already. =/
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top