Nissan Versa Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, Wanted to introduce myself. Bought a used 2009 Nissan Versa last October and have been loving it so far. It's the most basic model, manual transmission, manual windows & locks. I'm kickin it old school with this car.
It has some electrical issues like the tire sensors going off randomly when tire pressure is fine. Also, more pressing, is the issue that the dash lights don't work when the headlights are turned on. I joined this forum to look for answers to these things specifically.
Thanks!
 

·
Registered
Joined
·
560 Posts
Do you have an aftermarket radio?
If wired incorrectly, the dash lights WILL not work.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi! Thanks for replying so quickly.
It's the original radio, but I suspect it's either a wiring issue or a fuse that's blown. I've been looking around the forum and am going to check the fuses today.
Already double checked the dimmer switch, and that's not the problem. Wish it was that simple!
 

·
Registered
Joined
·
560 Posts
OK. First off go to www.nicoclub.com and download the service manuals for free!

Check fuses in the IDPM(fuse box) under the hood. It is a white box with a black lid by the battery.
All fuses, relays and wiring are in the black lid.
Look for fuse 37 10A .
52 15A
53 20A
And fuse block inside car 6, 8, 20 all 10A
 

·
Registered
2007 Versa s hatch 6spd
Joined
·
20 Posts
Welcome!
Your tire pressure sensors are probably shot. They generally last 5-10 years. When I got my wheels swapped I opted to go without since I am diligent about checking them myself. Just need to black the light out now. They will set you back $100-250 in the shop.

I picked up my 2007 hatch 6 spd back in January and have been enjoying the car. Is yours a hatch or sedan?
 
1 - 5 of 5 Posts
Top