Nissan Versa Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all,

I am glad I found this forum. I am a new member and I have an A.C. issue with my wife's 07 Versa hatchback.

When it's hot and I am driving, I would turn the AC on at 4 and put it to very cold. The AC blow normally from the front blowers. After about fifteen minutes or so, the blower pressure would decrease to as if I had it on a 1 setting or lower. After messing around with it for a bit, I found that if I turn the heat on for five minutes, then turn on the air after, it will continue to blow on 4 again, for five minutes, and then decrease to like a 1, and so on and so on.

I am not a mechanic or anything like that, but it seems as if the pipes or something is freezing over, and I lose pressure, because if I turn on the heat, it never decreases in power.

I am assuming some type of thermostat is broken or something?

Any help will be much appreciated... Thank you all with my first post!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks!

Is this something that I can change myself or will I have to take it in? Meaning, do I just unplug and replace something, or do i have to deal with recharging freon, etc?

Also, I haven't added any freon since I bought the car and I have about 85k miles on it, could this be the issue?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top