Nissan Versa Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have been having issues with my vehicle lately, I took my vehicle to the mechanics and was told that I have bad sensors and I replaced that. A few month went by, same problem came back and here is the problem I have gotten code P0705, I took my vehicle to another mechanic and was told my taillight compartments have corrosion in both of them, so I replaced. A few later, same problem and code came back, so my vehicle right taillight signal doesn’t work and it flashed rapidly too and my dashboard drive indicator doesn’t illuminate whenever I stepped on the break pad or turn the signal on, check engine came on too. I have replaced the taillight light bulbs multiple times. Reverse lights don’t illuminate when in reverse or in drive gear, at some same it harsh to switch into reverse gear too.
So, my neighbor told me it can be Faulty ground wiring connection issues or bad fuses, maybe frayed/damaged wiring to the TRS.
I have taken my vehicle to the dealer and mechanic multiple times and I’m frustrated at this times.
Any suggestions what could be an issue with my vehicle?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
any codes, outside of the p0705?
what did the dealership say what was wrong?
they said, it may have been moisture got in the taillight or the sensors are bad. I changed both and still same issues came back, so at this I am very sure they don’t know what the hell wrong with it. I took my vehicle back like 3X to them and still their mechanics check them out and still saying it could be the ground wiring issue.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
As frustrating and expensive as it is, it may be time to take it to another mechanic.
yep, that what I’m going to be doing, my friend whois a mechanic will come by and take a look at it and see what wrong with it. I have changed the taillight bulbs so many time and it kept going out a d the signal light whenever I turn the right hand signal on it flashes so rapidly and now whenever I put the gear in drive it make that kickback, it act as if it don’t get enough power to it. So many issues that is going on with this car and no one seem to know what is going on with it.
 
1 - 5 of 5 Posts
Top